Bug 12198 - boot fails unless "acpi=off" - Acer Aspire 3050
Summary: boot fails unless "acpi=off" - Acer Aspire 3050
Status: REJECTED UNREPRODUCIBLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-11 07:52 UTC by Ivan S. Zapreev
Modified: 2009-02-04 18:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: ---


Attachments
acpidump of working kernel without acpi=off (133.43 KB, text/plain)
2009-01-02 06:35 UTC, Luís Otávio
Details
acpidump of latest kernel with acpi=off (133.43 KB, text/plain)
2009-01-02 06:37 UTC, Luís Otávio
Details
This is the dmesg of working kernel 2.6.27-6-generic without acpi=off (58.63 KB, text/plain)
2009-01-05 05:57 UTC, Luís Otávio
Details
This is the scrren of boot with latest ubuntu kernel (239.26 KB, image/png)
2009-01-05 06:09 UTC, Luís Otávio
Details

Description Ivan S. Zapreev 2008-12-11 07:52:28 UTC
Just a small summary of my experience with the ACPI problems and Acer laptops.

This seems to be a DSDT and Linux-kernel bug. I have recently tried Ubuntu 8.04, Open SUSE 10.2, Fedora 10 and some other less known distribution on my Acer Aspire 3050. They all have the same problem, NO booting with ACPI. In case ACPI is off the system boots but there is no wireless or wired Internet and no power down. I am not even mentioning suspend and hibernate.

Now, from all I've read this seems to be caused by incorrect DSDT tables supplied by the vendor (Acer). I've also found a project that presumably supplies fixed DSDT tables for some systems: http://acpi.sourceforge.net/dsdt/

Another thing, it seems that all the current Main stream Linux distributions use the same flawed kernel. I.e. a kernel that somehow can not overcome problems in the DSDT table or may be the DSDT table supplied with the kernel is wrong or smth. I myself have no clue. Still, people claim that they could run Ubuntu 7.10 on Acer with no problems so it seems to be a regression bug.

I hope someone takes care of this bug, because I thinks it's been around a year since things went wrong .... it is about time some one fixes it!

There is some discussion about this problem in here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/191871
Comment 1 Zhang Rui 2008-12-11 18:17:20 UTC
please boot with acpi=off and get the acpidump output.

it would be great if you can attach the screenshot when the system hangs(remove the kernel option "splash"/"rhgb"/"quiet" before boot).

As this is a kernel bugzilla, you'd better use a vanilla kernel instead of the destro ones.
And in order to make the problem clear, could you please tell me,
1. what's the latest working release and what's the earliest failing release?
2. what workarounds have you guys tried and what's the results?
3. how do you know it's a DSDT problem? and is there a DSDT you get that can make your laptop work correctly?
Comment 2 ykzhao 2008-12-12 02:52:26 UTC
Will you please try the latest kernel(2.6.28-rc7) and see whether the system can be booted with ACPI enabled?
    Will you please check whether this is the duplicate of bug 8953?
    Thanks.
Comment 3 Len Brown 2008-12-12 13:19:50 UTC
> I've also found a project that presumably supplies
> fixed DSDT tables for some systems: http://acpi.sourceforge.net/dsdt/

Linux's goal is to run on all machine w/o users resorting
to modifying the firmware, and thus that web page is both
counter-productive, and defunct.  If your machine is brand-new,
see if there is a BIOS update for it, otherwise we should
seek to get Linux to run on the unmodified BIOS.

here's random guess, in addition to answering the questions above,
please try booting with pci=nommconf
Comment 4 Luís Otávio 2008-12-22 04:40:20 UTC
I have a Acer Aspire 5050-3284 with the same problem. I use the Kubuntu 8.10 with kernel 2.6.27-6-generic #1 SMP Tue Oct 7 04:15:23 UTC 2008 x86_64 GNU/Linux, the system works fine, withou battery and webcam. 

I try pci=nommconf and does not work with the newest kernel 2.6.27-11-generic. With the Kubuntu's 7.10 first kernel, works fine too with webcam ok, but with the atualizations of the kernel, does not work anymore. 

I do not modify BIOS.
Comment 5 Zhang Rui 2008-12-28 17:48:21 UTC
in order to debug this issue, please follow the instructions in comment #1 and #2, :)
Comment 6 ykzhao 2008-12-28 23:50:20 UTC
Hi, Ivan & Luis
    How about this issue? 
    Will you please attach the output of acpidump?
    Thanks.
    
Comment 7 Ivan S. Zapreev 2008-12-29 10:49:02 UTC
I have installed Ubuntu 7.10 on that Acer I used, will ACPI dump of that version help in any way? Alternatively I could try to run later Ubuntu version in a Virtual Box an see what happens ... Would it be a solution, or better yet, which way do you prefer more?
Comment 8 Zhang Rui 2008-12-29 17:56:24 UTC
no, you don't need to try a later Ubuntu version.
Just go to www.kernel.org and download the latest vanilla kernel source. :)
Comment 9 Luís Otávio 2009-01-02 06:35:12 UTC
Created attachment 19604 [details]
acpidump of working kernel without acpi=off  

This is the acpidump of a working kernel 2.6.27-6-generic
Comment 10 Luís Otávio 2009-01-02 06:37:35 UTC
Created attachment 19605 [details]
acpidump of latest kernel with acpi=off  

kernel with acpi=off and not working acpi.
Comment 11 Luís Otávio 2009-01-02 06:44:47 UTC
1. what's the latest working release and what's the earliest failing release?
The latest working release is 2.6.27-6-generic

2. what workarounds have you guys tried and what's the results?
I just try modify kernel parameters like acpi=off, nolapic , noacpi, etc.

3. how do you know it's a DSDT problem? and is there a DSDT you get that can
make your laptop work correctly?
I do not know if is a DSDT problem.

I try to compile the newest kernel and have no success on it, is there a tutorial to compile under ubuntu? I follow this http://www.howtoforge.com/kernel_compilation_ubuntu and do not work.
Comment 12 Zhang Rui 2009-01-04 00:43:54 UTC
(In reply to comment #11)
> 1. what's the latest working release and what's the earliest failing release?
> The latest working release is 2.6.27-6-generic
> 
do you mean the 2.6.27-6-generic can work well on your laptop?
But I thought you have never get a Linux kernel running successfully with ACPI on, right?

> 2. what workarounds have you guys tried and what's the results?
> I just try modify kernel parameters like acpi=off, nolapic , noacpi, etc.
> 
so only acpi=off works, right?

> I try to compile the newest kernel and have no success on it, is there a
> tutorial to compile under ubuntu? I follow this
> http://www.howtoforge.com/kernel_compilation_ubuntu and do not work.
> 
first please click this link http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 to get the latests source code, build your new kernel with the old kernel config file.


BTW: it's really helpful if you can attach the screen shot when the laptop hangs during boot.
Comment 13 Luís Otávio 2009-01-04 21:24:18 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > 1. what's the latest working release and what's the earliest failing
> release?
> > The latest working release is 2.6.27-6-generic
> > 
> do you mean the 2.6.27-6-generic can work well on your laptop?
> But I thought you have never get a Linux kernel running successfully with
> ACPI
> on, right?

Yes, the kernel 2.6.27-6-generic work well without acpi=off . The first kernel of ubuntu 7.10 works well to.

> > 2. what workarounds have you guys tried and what's the results?
> > I just try modify kernel parameters like acpi=off, nolapic , noacpi, etc.
> > 
> so only acpi=off works, right?
With the acpi=off the sistem boots, but the ethernet card does not work. The wireless card, webcam, bluetooth never works in any kernel.

> > I try to compile the newest kernel and have no success on it, is there a
> > tutorial to compile under ubuntu? I follow this
> > http://www.howtoforge.com/kernel_compilation_ubuntu and do not work.
> > 
> first please click this link
> http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.28.tar.bz2 to get the
> latests source code, build your new kernel with the old kernel config file.
I download the latest kernel 2.6.28 and follow the instructions of the link http://www.howtoforge.com/kernel_compilation_ubuntu and do not work, is there any other that I can follow?
> 
> BTW: it's really helpful if you can attach the screen shot when the laptop
> hangs during boot.
> 
I will send the screen shot.
Comment 14 ykzhao 2009-01-04 21:40:19 UTC
Hi, Luis
    From the acpidump it seems that the \_SB.PHSR object is called in the course of EC initialization. But unfortunately the \_SB.PHSR object can't be found. And this issue can be fixed by the following commit:
    >commit 20edd74fcf9ad02c19efba0c13670a7b6b045099
    >Author: Zhao Yakui <yakui.zhao@intel.com>
    >Date:   Fri Oct 17 02:02:44 2008 -0400
     >ACPI: Ignore AE_NOT_FOUND error of EC _REG method and continue to initialize EC
    The above commit is shipped in 2.6.28-rc1. And it is not shipped in the stable kernel of 2.6.27-6. I don't know whether the ubuntu 2.6.27-6 is based on the 2.6.27.6 stable kernel.
    Will you please attach the output of dmesg after the system is booted with ACPI enabled?(The ubuntu 2.6.27-6 kernel).
    Thanks.
Comment 15 Luís Otávio 2009-01-05 05:57:16 UTC
Created attachment 19662 [details]
This is the dmesg of working kernel 2.6.27-6-generic without acpi=off

This is the dmesg of working kernel 2.6.27-6-generic without acpi=off, the wired card works fine. The webcam and bluetooth doesn't work.
Comment 16 Luís Otávio 2009-01-05 06:09:10 UTC
Created attachment 19663 [details]
This is the scrren of  boot with latest ubuntu kernel

This is the scrren of  boot with latest ubuntu kernel
Comment 17 ykzhao 2009-01-05 17:05:12 UTC
Hi, Luis
    From the log in comment #15 it seems that there exists the following warning and the EC device can't work well.
    >[    0.816053] ACPI Error (psargs-0358): [\_SB_.PHSR] Namespace lookup failure, AE_NOT_FOUND
    >[    0.816073] ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.PCI0.LPC0.EC0_._REG] (Node ffff88015fa35a40), AE_NOT_FOUND
    >[   76.108043] ACPI: EC: acpi_ec_wait timeout, status = 0x80, event = "b0=1"
    >[   76.108060] ACPI: EC: read timeout, command = 128
    >[   76.112236] ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080609]
    >[   76.112270] ACPI Error (psparse-0530): Method parse/execution failed [\_SB_.ACAD._PSR] (Node ffff88015fa39020), AE_TIME
    
    As there exists the above error messge, the system can't work well although it can be booted without ACPI.(The battery info can't be reported correctly).
    Will you please try the latest upstream kernel and see whether the issue still exists?(2.6.28)
    Thanks.
Comment 18 Luís Otávio 2009-01-14 09:54:06 UTC
Since 2009-01-05, I try to compile the kernel 2.6.28 via GIT, it seems that work without acpi=off, because the sistem boot ok, but the video do not. The sistem do not freeze, I always can use the ctr+alt+del and works.

I will wait the official kernel 2.6.28 from ubuntu. 

Thanks all.
Comment 19 Leopoldo Guzman 2009-01-19 20:03:53 UTC
Hi,
I have a notebook Acer Aspire 3050-1092. It is running a dual boot install with WinVista Home Basic and Ubuntu 8.04.1. I compiled kernel 2.6.28 and it booted without acpi=off but don't have wifi and sound. I tried to compile madwifi 0.9.4 and ndiswrapper 1.53 but they have errors. Also I have tried ath5k driver from kernel. Wifi adapter apparently worked this way but couldn't connect to an AP with WPA Personal encryption.
Comment 20 Luís Otávio 2009-01-22 10:09:49 UTC
Hi all,

I try the alpha 3 release of ubuntu 9.04 with kernel 2.6.28.4 and works without acpi=off, my concern is in the first kernel of ubuntu 7.10 works without acpi=off but the newests kernels of this ubuntu version did not work, in the version ubuntu 8.04 none of kernels works, in the version 8.10 works until kernel 2.6.27.6, the problem always back, is there a way to solve this forever? 

The wireless cards does not work in any version.

Thanks all!
Comment 21 Leopoldo Guzman 2009-01-25 11:10:48 UTC
Hello again,
  I now got my notebook (Aspire 3050-1092) almost completely functional with kernel 2.6.28. Apparently the wifi adapter (AR5007EG) failed to work with ath5k module and NetworkManager, but setting it up manually or with wicd works OK. I was not compiled modules for the sound card and sd memory card when compiled the kernel, so did later and now everything works, except for the wifi LED, but the switch does.
Comment 22 ykzhao 2009-02-04 17:40:07 UTC
Hi, Rui
   Now it seems that the box can be booted normally on the kernel of 2.6.28. How about close this bug?
   Thanks.
Comment 23 Zhang Rui 2009-02-04 18:21:34 UTC
okay. the box can boot without acpi=off now. close this bug.
please file a new problem to the proper category if something doesn't work when ACPI is enabled.

Note You need to log in before you can comment on or make changes to this bug.