Bug 121851 - X450LCP touchpad stops working after suspend/resume
Summary: X450LCP touchpad stops working after suspend/resume
Status: RESOLVED DUPLICATE of bug 107971
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-10 18:15 UTC by Marcos Souza
Modified: 2016-07-17 21:22 UTC (History)
0 users

See Also:
Kernel Version: mainline
Tree: Mainline
Regression: No


Attachments
ACPI data (240.21 KB, application/gzip)
2016-07-10 18:15 UTC, Marcos Souza
Details

Description Marcos Souza 2016-07-10 18:15:19 UTC
Created attachment 222641 [details]
ACPI data

At first, this laptop's touch pad didn't worked, so I sent a patch[1] to make it work. But, while it works great when the laptop is turned on, it stops working again after a suspend/resume.

When my machine turns on, I can see some messages
[ 1106.752325] ACPI Warning: \_SB.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160108/nsarguments-95)
[ 1106.752704] ACPI: \_SB_.PCI0.RP05.PEGP: failed to evaluate _DSM
[ 1106.752710] ACPI Warning: \_SB.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160108/nsarguments-95)

(These messages are from drivers/acpi/acpica/nspredef.c)

And also these:
[    1.643977] pci 0000:04:00.0: optimus capabilities: enabled, status dynamic power,
[    1.643980] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.RP05.PEGP handle
[   15.647623] ACPI Warning: SystemIO range 0x000000000000F040-0x000000000000F05F conflicts with OpRegion 0x000000000000F040-0x000000000000F04F (\SMB0) (20150930/utaddress-254)

[    1.678372] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[26972.264060] ACPI: \_SB_.PCI0.RP05.PEGP: failed to evaluate _DSM

(_DSM are reporrted by nouveau_acpi.c, so I'm aware this could be happening because of my graphic card).

Trying to solve this problem, I also tested new vanilla kernels and it gave the same warnings.

I attached a tar containing data extracted from my laptop by using wget http://lekensteyn.nl/files/get-acpi-info.sh.


Please let me know if I can give you more info. Thanks!

[1] https://lkml.org/lkml/2014/9/23/610
Comment 1 Rafael J. Wysocki 2016-07-15 23:14:52 UTC
This most likely is an input driver problem, so reassigning.

I don't think that the problem is related to the ACPI messages you see.
Comment 2 Marcos Souza 2016-07-16 16:43:55 UTC
Thanks for pointing the problem as related to ACPI. After a suspend/resume, input5 is removed from sysfs:


[marcos@xfiles ~]$ cat /sys/class/input/input5/name 
ETPS/2 Elantech Touchpad

...
suspend
resume
...

[marcos@xfiles ~]$ cat /sys/class/input/input5/name 
cat: /sys/class/input/input5/name: No such file or directory

[marcos@xfiles ~]$ cat  /sys/class/input/input*/name
Lid Switch
Asus WMI hotkeys
USB2.0 HD UVC WebCam
HDA Intel HDMI HDMI/DP,pcm=3
HDA Intel HDMI HDMI/DP,pcm=7
HDA Intel HDMI HDMI/DP,pcm=8
HDA Intel PCH Mic
HDA Intel PCH Headphone
Sleep Button
Power Button
AT Translated Set 2 keyboard
 USB OPTICAL MOUSE
Video Bus
Video Bus
PC Speaker

So, input5 is completely removed from system and not recreated. Trying to figure out what's happening here.
Comment 3 Marcos Souza 2016-07-17 21:22:46 UTC

*** This bug has been marked as a duplicate of bug 107971 ***

Note You need to log in before you can comment on or make changes to this bug.