Bug 12178 - Xorg crash at first start
Xorg crash at first start
Status: CLOSED DUPLICATE of bug 12216
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-12-07 13:33 UTC by Rafael J. Wysocki
Modified: 2008-12-23 06:15 UTC (History)
0 users

See Also:
Kernel Version: 2.6.28-rc7-105-gfeaf384
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-12-07 13:33:20 UTC
Subject    : Xorg crash at first start
Submitter  : Cédric Godin <cedric@belbone.be>
Date       : 2008-12-04 14:26
References : http://marc.info/?l=linux-kernel&m=122840082828098&w=4
Notify-Also : Keith Packard <keithp@keithp.com>
Notify-Also : "Dave Airlie" <airlied@gmail.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-12-07 13:34:45 UTC
Reportedly caused by:

commit 52440211dcdc52c0b757f8b34d122e11b12cdd50
Author: Keith Packard <keithp@keithp.com>
Date:   Tue Nov 18 09:30:25 2008 -0800

   drm: move drm vblank initialization/cleanup to driver load/unload

   drm vblank initialization keeps track of the changes in driver-supplied
   frame counts across vt switch and mode setting, but only if you let it by
   not tearing down the drm vblank structure.

   Signed-off-by: Keith Packard <keithp@keithp.com>
   Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 52440211dcdc52c0b757f8b34d122e11b12cdd50
Comment 2 Rafael J. Wysocki 2008-12-23 06:12:07 UTC
On Tuesday, 23 of December 2008, Cédric Godin wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12178
> > Subject		: Xorg crash at first start
> > Submitter	: Cédric Godin <cedric@belbone.be>
> > Date		: 2008-12-04 14:26 (17 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=52440211dcdc52c0b757f8b34d122e11b12cdd50
> > References	: http://marc.info/?l=linux-kernel&m=122840082828098&w=4
> >
> >
> It seems that the bug #12216 is the same bug. I tested the patch posted
> in it and everything is back to normal. Many thanks.

Comment 3 Rafael J. Wysocki 2008-12-23 06:15:49 UTC

*** This bug has been marked as a duplicate of bug 12216 ***

Note You need to log in before you can comment on or make changes to this bug.