Bug 12158 - commit b1ee26b freezes system on switching from X to text console
commit b1ee26b freezes system on switching from X to text console
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-12-03 14:42 UTC by Rafael J. Wysocki
Modified: 2008-12-11 11:37 UTC (History)
1 user (show)

See Also:
Kernel Version: commit b1ee26b
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-12-03 14:42:38 UTC
Subject    : commit b1ee26b "radeonfb: accelerate imageblit and other improvements" freezes system on switching from X to text console
Submitter  : Gaudenz Steinlin <gaudenz@debian.org>
Date       : 2008-11-25 19:44
References : http://marc.info/?l=linux-kernel&m=122764344231140&w=4
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-12-03 14:44:11 UTC
First-Bad-Commit : b1ee26bab14886350ba12a5c10cbc0696ac679bf

Caused by:

commit b1ee26bab14886350ba12a5c10cbc0696ac679bf
Author: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date:   Wed Oct 15 22:03:46 2008 -0700

    radeonfb: accelerate imageblit and other improvements

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Acked-by: David S. Miller <davem@davemloft.net>
    Cc: Krzysztof Halasa <khc@pm.waw.pl>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

Note You need to log in before you can comment on or make changes to this bug.