Bug 12124 - After suspend to RAM I cannot wake up my computer again
After suspend to RAM I cannot wake up my computer again
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-11-30 06:50 UTC by Diego Ocampo
Modified: 2012-05-14 16:25 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-9-generic
Tree: Mainline
Regression: No


Attachments
file with the result of the acpidump command (149.88 KB, application/octet-stream)
2008-12-04 15:15 UTC, Diego Ocampo
Details
result of the command lspci -vxxx (24.53 KB, application/octet-stream)
2008-12-04 15:16 UTC, Diego Ocampo
Details
copy of the dmesg output before suspend (47.07 KB, application/octet-stream)
2008-12-04 15:18 UTC, Diego Ocampo
Details
the last dmseg_before that i made (47.39 KB, application/octet-stream)
2008-12-05 07:20 UTC, Diego Ocampo
Details
use the RTC cmos area to track where the suspend/resume hangs (5.60 KB, patch)
2008-12-07 17:16 UTC, ykzhao
Details | Diff
dmesg_after (86.38 KB, application/octet-stream)
2008-12-08 05:31 UTC, Diego Ocampo
Details

Description Diego Ocampo 2008-11-30 06:50:14 UTC
Distribution: Ubuntu 8.10 Intrepid
Hardware Environment: Samsung r70/a009
Software Environment: Gnome 2.24 or kde 4.1.3
Problem Description: After suspend to RAM I cannot wake up my computer again. In /var/log/messages there is nothing related with this moment (like if it just do nothing) and the computer is on but with the screen off and without noise of anything (not the hard-disk nor the processor fan) working.

Steps to reproduce: I make the suspend using the shutdown -> suspend button from the gnome menu (and the same for kde).
Comment 1 ykzhao 2008-12-04 01:59:46 UTC
Will you please attach the output of acpidump, lspci -vxxx, dmesg?
Thanks.
Comment 2 ykzhao 2008-12-04 02:03:08 UTC
Will you please add the boot option of "acpi_sleep=s3_beep" and do the following test ?
   a. kill the process which is using /proc/acpi/event
   b. dmesg >dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after
   c. press the power button and see whether the system can be resumed
    
   If it can't be resumed, please confirm whether the beep voice can be heard and whether there exists the file of dmesg_after.
    Thanks.
Comment 3 Diego Ocampo 2008-12-04 15:15:54 UTC
Created attachment 19150 [details]
file with the result of the acpidump command
Comment 4 Diego Ocampo 2008-12-04 15:16:52 UTC
Created attachment 19151 [details]
result of the command lspci -vxxx
Comment 5 Diego Ocampo 2008-12-04 15:18:12 UTC
Created attachment 19152 [details]
copy of the dmesg output before suspend
Comment 6 Diego Ocampo 2008-12-04 15:23:10 UTC
I put the results of what you asked me but i couldn't do the "dmesg >dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after" because i get a "bash: /sys/power/state: Permission denied" even if i run it as super-user.

I am not sure if i put well the acpi_sleep=s3_beep option in the grub loader but i think so, what i didn't know is how to look which processes are using /proc/acpi/event, i tried with "ps aux | grep event" and i got:

"root         9  0.0  0.0      0     0 ?        S<   Dec04   0:00 [events/0]
root        10  0.0  0.0      0     0 ?        S<   Dec04   0:00 [events/1]
root      4874  0.0  0.0   4864  1640 ?        Ss   Dec04   0:00 /usr/sbin/acpid -c /etc/acpi/events -s /var/run/acpid.socket
root      5398  0.0  0.0  20048  1184 ?        S    Dec04   0:00 hald-addon-input: Listening on /dev/input/event3 /dev/input/event8 /dev/input/event9 /dev/input/event5 /dev/input/event4 /dev/input/event6 /dev/input/event11 /dev/input/event1"

so it seems nothing is using it.. i hope i helped, if you could give me more instructions of how to boot with the "acpi_sleep=s3_beep" command and how to do "dmesg >dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after" without error message, i will try again.
Thank you very much for your help.

Comment 7 ykzhao 2008-12-04 17:24:24 UTC
Hi, Diego
    If you have no permission of /sys/power/state, how can you do the suspend/resume?
    Please login as root and do the test as mentioned in comment #2.
    Please use the command of "lsof /proc/acpi/event" to get the process using the /proc/acpi/event.
    Thanks.
Comment 8 Diego Ocampo 2008-12-05 07:18:42 UTC
Hi, well, the problem is that i am not a linux expert, but i am using ubuntu 8.10 and it doesn't allow me to login as a root user, so i was using the sudo command, but now i login as root in a terminal, and i could finally do the "dmesg >dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after" command. What happened is that my computer suspends but in a different way, the power button led was still on, and the caps lock led (and other led i don't know what's for) were blinking. I tried to resume pressing the power button and no way!, also (after restart the computer) i checked if there is a dmsesg_after file, and there is not but i attach the dmesg_before.

About the question: "If you have no permission of /sys/power/state, how can you do the suspend/resume?", well i don't know anything about it, but i am just using ubuntu like everyone so i should be able to suspend it no?...

Could you give me an example of how to edit the menu.lst file for grub in order to add the "acpi_sleep=s3_beep" option?, i couldn't do it yet.

Thanks.

Comment 9 Diego Ocampo 2008-12-05 07:20:30 UTC
Created attachment 19157 [details]
the last dmseg_before that i made 

the last dmseg_before that i made
Comment 10 ykzhao 2008-12-07 05:59:10 UTC
Hi, Diego
    Understand what you said.
    a) If you have no permission of /sys/power/state, maybe we can't do the suspend/resume. And it is very convenient to do the suspend/resume by using /sys/power/state
    b) How to add the boot option of "acpi_sleep=s3_beep". The following is the example:
    title Fedora Core (2.6.27.4)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.27.4 ro root=LABEL=/ apic=debug resume=/dev/sda3 acpi_sleep=s3_beep
        initrd /boot/initrd-2.6.27.4.img

    c) From the description it seems that there is no file of dmesg_after in your test. I am not sure what you have done is right. Will you please try it again?
    Thanks.
    
Comment 11 Diego Ocampo 2008-12-07 07:50:28 UTC
Ok, i will try it again and i put the result this night, just i want to ask: is it important to have this resume=/dev/sdax in the menu.lst config file?? because i don't have any resume parameter..
And i am quite sure that there is not dmesg_after after i lunch the "dmesg >dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after" command, maybe it is because it can never wake up..
Comment 12 ykzhao 2008-12-07 17:12:51 UTC
Hi, Diego
    You needn't add the option of "resume=/dev/sdax" in the menu.lst. I copy it from the menu.lst on my box. It doesn't matter if you delete it.
    
    If there is no file of dmesg_after, please check whether the beep voice can be heard.
    thanks.
Comment 13 ykzhao 2008-12-07 17:16:49 UTC
Created attachment 19202 [details]
use the RTC cmos area to track where the suspend/resume hangs

Hi, Diego
    If you can confirm that there is no file of dmesg_after after pressing the power button, will you please use the debug patch on the latest kernel(2.6.28-rc6) and do the following test?
    a. add the boot option of "acpi_sleep=s3_beep"
    b. after the system is booted, please kill the process which is using the /proc/acpi/event( use the command of "lsof /proc/acpi/event" to get the process using the /proc/acpi/event)
    c. echo 25 > /proc/cmos; echo mem > /sys/power/state
    d. press the power button and see whether the system can be resumed.

   If the system can't be resumed, please reboot the system. After the system is rebooted, please cat /proc/cmos and attach the output of dmesg.
   Thanks.
Comment 14 Diego Ocampo 2008-12-08 05:31:58 UTC
Created attachment 19207 [details]
dmesg_after
Comment 15 Diego Ocampo 2008-12-08 05:32:14 UTC
Hi again, this time i got a dmesg_after, (maybe i did something wrong the other time) I attach it to you, i hope it helps to solve the problem.
I didn't patch the kernel, and my kernel is: 2.6.27-9-generic that is the last one i can get with ubuntu without compile it by myself (I don't know how to do it!)
Comment 16 ykzhao 2008-12-15 01:25:22 UTC
Hi, Diego
    Thanks for the test.
    From the log in comment #14 it seems that the system can be resumed successfully from S3. But the remaining issue is that the screen is off. And the problem is related with nvidia graphics driver.
    So this bug will be re-assigned to the category of nvidia graphics driver.
    thanks.
   
Comment 17 ykzhao 2008-12-15 01:29:24 UTC
Hi, Nvidia Guys
    From the log in comment #14 it seems that the system can be resumed from S3. But the screen remains blank.
    Will you please look at this issue? The display can't work well after the suspend/resume.
    thanks.
Comment 18 Rafael J. Wysocki 2011-01-16 21:56:08 UTC
This should be fixed in 2.6.37 with the nouveau driver.  Can you please test?

Note You need to log in before you can comment on or make changes to this bug.