Bug 12115 - Brightness on thinkpad T61 not settable after DPMS screen blanker
Brightness on thinkpad T61 not settable after DPMS screen blanker
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2008-11-28 02:44 UTC by Hanno Boeck
Modified: 2013-04-09 06:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc6
Tree: Mainline
Regression: ---


Attachments
xrandr --verbose output (2.66 KB, text/plain)
2008-12-01 02:29 UTC, Hanno Boeck
Details
acpidump (317.30 KB, text/plain)
2008-12-01 02:33 UTC, Hanno Boeck
Details

Description Hanno Boeck 2008-11-28 02:44:13 UTC
I have a problem with the screen brightness.

I've configured my kernel like described here:
http://www.thinkwiki.org/wiki/LCD_Brightness
(disabling CONFIG_THINKPAD_ACPI_VIDEO and using acpi-video)

It usually works fine, brightness can be set through the proc interface and through the fn-buttons. Though after xorg blanks the screen with dpms, this doesn't work. Screen stays on very low brightness, setting with the proc interface has no effect on the screen. After restarting X, everything works fine again.

I'm not sure if this is the right place to report this (or if this is some xorg-driver issue?), if not please point me to the right place.
Comment 1 Zhang Rui 2008-11-30 19:19:44 UTC
please attach the acpidump output.
you can use the latest pmtools here:
http://www.lesswatts.org/downloads/#acpi

please attach the result of "xrandr --verbose"
Comment 2 Hanno Boeck 2008-12-01 02:28:45 UTC
This seems to have been fixed within latest git version of xf86-video-intel - at least I can't reproduce it any more and that's the only thing I've updated in the meantime.

Do you still want my acpidump and xrandr? I'll attach them.
Comment 3 Hanno Boeck 2008-12-01 02:29:06 UTC
Created attachment 19088 [details]
xrandr --verbose output
Comment 4 Hanno Boeck 2008-12-01 02:33:35 UTC
Created attachment 19089 [details]
acpidump
Comment 5 Hanno Boeck 2008-12-01 03:43:50 UTC
Hmm, sorry for the confusion but I just got it again...

Seems it happens occasionally. Maybe just on the second time, I'll try to check that.
Comment 6 Zhang Rui 2008-12-01 19:45:16 UTC
len said that it has been fixed after upgrading to FC10, could you please confirm it?
Comment 7 Hanno Boeck 2008-12-02 03:03:20 UTC
FC10 means Fedora? I'm not using that.
Comment 8 Hanno Boeck 2008-12-02 13:23:29 UTC
Seems kernel 2.6.27-rc7 brought improvements - at least I can't reproduce the problem any more at the moment.

I'll keep an eye on it.
Comment 9 Zhang Rui 2008-12-02 16:57:46 UTC
good news. :)
close this bug,
Hanno, please re-open it if you can reproduce the problem in the latest upstream kernel again.

Note You need to log in before you can comment on or make changes to this bug.