Bug 12105 - No hard drive on resume from suspend on ECS NFORCE9M-A/NVIDIA GeForce8100 SATA
No hard drive on resume from suspend on ECS NFORCE9M-A/NVIDIA GeForce8100 SATA
Status: RESOLVED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Tejun Heo
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-11-26 05:10 UTC by Shawn Landden
Modified: 2009-10-29 10:44 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.28-rc5
Tree: Mainline
Regression: No


Attachments
lspcivv (14.06 KB, text/plain)
2008-11-30 06:06 UTC, Shawn Landden
Details
lspci as root (26.37 KB, text/plain)
2008-11-30 06:07 UTC, Shawn Landden
Details
/proc/scsi/scsi (654 bytes, text/plain)
2008-11-30 06:24 UTC, Shawn Landden
Details
lspci vvv (26.71 KB, text/plain)
2009-01-20 03:39 UTC, Shawn Landden
Details
lspcivvv (26.69 KB, text/plain)
2009-01-20 03:46 UTC, Shawn Landden
Details
lsmod (2.12 KB, text/plain)
2009-01-20 03:47 UTC, Shawn Landden
Details
nv-ht-quirk-on-resume.patch (742 bytes, patch)
2009-04-26 03:40 UTC, Tejun Heo
Details | Diff
failed soft reset (17.22 KB, text/plain)
2009-10-29 10:44 UTC, Shawn Landden
Details

Description Shawn Landden 2008-11-26 05:10:50 UTC
Latest working kernel version: Never
Earliest failing kernel version: 2.6.27-7-desktop (distribution)
Distribution: Ubuntu 8.10 - Desktop
Hardware Environment: ECS NFORCE9M-A motherboard, Phenom 9550+, two 500GB SATA on 2nd and 3rd ports, DVD-RW on ATA/133
Software Environment: 
Problem Description: When I resume from suspend all reads from the hard drive fail, the X environment is entirely static, and is anything works on the command line it is only certain commands in ram, anything else results in kernel errors about reading from disk, also errors of not being able to read/access swap partition on same drive

Steps to reproduce: Suspend to RAM, Click power button to turn on, try to do anything in resultant situation, disk read errors reign (or it just freezes)
Comment 1 Shawn Landden 2008-11-26 05:14:55 UTC
x64, Controller chip is Nvidia GeForce8100 (integrated)
Comment 2 Tejun Heo 2008-11-26 07:45:12 UTC
Can you get kernel log after resume?  You'll probably need to mount a usb stick, cd into it and run dmesg once so that everything necessary is on memory and then suspend / resume and do "dmesg > dmesg.out" there.
Comment 3 Shawn Landden 2008-11-30 01:37:30 UTC
I havnt been able to even get a screen now, and as the passwd etc files are not accessable i cant log in via ssh either after resuming, how should i debug this
Comment 4 Tejun Heo 2008-11-30 02:06:47 UTC
Rafael, can you please help here?  Thanks.
Comment 5 Shawn Landden 2008-11-30 02:53:11 UTC
I have 8G of ram, but thats not quite enough to loop mount my entire root partition into ram, or is there a simpler way?
Comment 6 Rafael J. Wysocki 2008-11-30 05:34:28 UTC
Please attach the output of 'lspci -vv' (please choose the 'plain text' type of the attachment).
Comment 7 Shawn Landden 2008-11-30 06:06:25 UTC
Created attachment 19078 [details]
lspcivv

i can remove non-free modules
Comment 8 Shawn Landden 2008-11-30 06:07:19 UTC
Created attachment 19079 [details]
lspci as root 

whoops
Comment 9 Shawn Landden 2008-11-30 06:24:29 UTC
Created attachment 19080 [details]
/proc/scsi/scsi
Comment 10 Shawn Landden 2008-11-30 06:39:20 UTC
also hibernate works, it only breaks on suspend-to-RAM
Comment 11 Shawn Landden 2009-01-20 03:39:03 UTC
Created attachment 19898 [details]
lspci vvv

still having this problem
Comment 12 Shawn Landden 2009-01-20 03:46:37 UTC
Created attachment 19899 [details]
lspcivvv

still having this problem
Comment 13 Shawn Landden 2009-01-20 03:47:08 UTC
Created attachment 19900 [details]
lsmod
Comment 14 Tejun Heo 2009-01-21 05:15:37 UTC
Can you then please try to set up a serial or netconsole?  Without failing logs, I can't tell what's going on.  In the kernel source tree, Documentation/serial-console.txt and Documentation/networking/netconsole.txt documents each.

Thanks.
Comment 15 TJ 2009-03-23 09:36:56 UTC
I suspect this is related to http://bugzilla.kernel.org/show_bug.cgi?id=12542

Looks like the same MCP78S hardware - in this user's original Ubuntu bug report

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/299553

I've asked for the output of "lspci -vvnn" to compare [vendor:device] IDs.
Comment 16 Damir Syabitov 2009-04-25 10:36:50 UTC
Hi all. Sorry for my english at first. My new HP HDX18 laptop doesn't wake up
to. After resume it can't find any hard drives. This can be reproduced in all
kernels and distributions, what i try (ubuntu 8.10 (amd64, x86), Gentoo 2008
(x86_64), Fedora 10 (x86, x86_64)). All distributions have 2.6.27 kernel. On
Gentoo i try kernel 2.6.29 - nothing change. When i try to boot from usb hdd
and get all kernel logs. Here they are:
http://unitedchat.ru/pub/hwinfo_and_logs.tar.gz .
If need more info - contact me, please dsyabitov at gmail.com
Comment 17 Tejun Heo 2009-04-26 02:12:48 UTC
Damir, what you're seeing is a different problem.  Looking up....  it's bko#12276.  Can you please attach kernel log and "lspci -nn" and dmidecode output there?

  http://bugzilla.kernel.org/show_bug.cgi?id=12276

I'll ping HP again.

Thanks.
Comment 18 Tejun Heo 2009-04-26 03:35:06 UTC
TJ: Can you please pull dmesg and lspci output from blp#334644?  It seems that MSI stops working after resuming.  cc'ing Peer Chen.

Hmm... Could it be due to missing RESUME quirk entry for nv_msi_ht_cap_quirk?  I'll prep a quick patch.
Comment 19 Tejun Heo 2009-04-26 03:40:25 UTC
Created attachment 21125 [details]
nv-ht-quirk-on-resume.patch

The patch is against 2.6.29.  Please test whether it makes any difference.  Thanks.
Comment 20 Shawn Landden 2009-10-14 18:02:28 UTC
This seems to be fixed in karmic 2.6.31

bug 12542 ?
Comment 21 Tejun Heo 2009-10-15 07:41:15 UTC
Yeah, this went in.  Thanks.
Comment 22 Shawn Landden 2009-10-29 10:35:04 UTC
While my main hard drive, the Western Digital ST3500630AS, is working great across suspends now, the Maxtor 6H500F0 is disappearing after a suspend; and I have to turn the computer off and on (not just a restart) to get it back. Hard drive problem?
Comment 23 Tejun Heo 2009-10-29 10:38:08 UTC
I'm afraid if soft resetting doesn't revive the drive, there isn't much driver can do about it.  :-(
Comment 24 Shawn Landden 2009-10-29 10:44:16 UTC
Created attachment 23580 [details]
failed soft reset

Yes, that seems to be the problem. Thanks for fixing the main bug.

Note You need to log in before you can comment on or make changes to this bug.