Bug 12103 - Neither `toshiba' nor `toshiba_acpi' load - Toshiba Satellite L300-11E
Neither `toshiba' nor `toshiba_acpi' load - Toshiba Satellite L300-11E
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: John Belmonte
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2008-11-26 00:46 UTC by Michael Lashkevich
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: ---


Attachments
dmidecode output (8.63 KB, text/plain)
2008-11-26 00:47 UTC, Michael Lashkevich
Details

Description Michael Lashkevich 2008-11-26 00:46:34 UTC
Latest working kernel version: unknown
Earliest failing kernel version: 2.6.22
Distribution: OpenSUSE 10.3 with any available kernel
Hardware Environment: Toshiba Satellite L300-11E
Software Environment:
Problem Description: When I try to load either 'toshiba' or 'toshiba_acpi' module by the 'modprobe' command it fails with the message:

FATAL: Error inserting toshiba (/lib/modules/2.6.28-rc3-git/kernel/drivers/char/toshiba.ko): No such device

or

FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.28-rc3-git/kernel/drivers/acpi/toshiba_acpi.ko): No such device

in stderr and

toshiba: not a supported Toshiba laptop

in the dmesg output.

Steps to reproduce: Log in as a root and do 'modprobe toshiba' or 'modprobe toshiba_acpi'.
Comment 1 Michael Lashkevich 2008-11-26 00:47:26 UTC
Created attachment 19031 [details]
dmidecode output
Comment 2 Zhang Rui 2008-12-08 17:58:27 UTC
Ping John,
any update on this?
Comment 3 John Belmonte 2008-12-09 04:51:00 UTC
If toshiba_acpi reports "no such device", that means your hardware/BIOS isn't supported by the driver.  The driver is perhaps too broadly named-- it was only intended to support Toshiba laptops having a specific ACPI function available.

As for the toshiba driver, I don't maintain it and can't comment.

Please close this bug.
Comment 4 Michael Lashkevich 2008-12-09 08:32:06 UTC
Ok, I have just understood that the backlight control I lacked can be achieved by loading the 'video' driver by hands, though cpufreq still does not work even with 'cpufreq_userspace' module.

Please, close the bug, I do not know how to do it. I am afraid to do something wrong.
Comment 5 Zhang Rui 2008-12-09 18:26:26 UTC
close this bug.
about the cpufreq issue.
please make sure CONFIG_X86_ACPI_CPUFREQ is set.

Note You need to log in before you can comment on or make changes to this bug.