Bug 12083 - snail boot on GA-EP45-DS5
Summary: snail boot on GA-EP45-DS5
Status: RESOLVED DUPLICATE of bug 13551
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Tejun Heo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-22 13:54 UTC by Nicolas Mailhot
Modified: 2009-07-02 11:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27.5
Tree: Mainline
Regression: Yes


Attachments
Boot logs (50.31 KB, text/plain)
2008-11-22 13:55 UTC, Nicolas Mailhot
Details
System lspci (180.39 KB, text/plain)
2008-11-22 13:55 UTC, Nicolas Mailhot
Details
Boot logs (50.28 KB, text/plain)
2008-11-23 15:13 UTC, Nicolas Mailhot
Details
dmidecode output (11.35 KB, text/plain)
2009-06-29 17:22 UTC, Nicolas Mailhot
Details

Description Nicolas Mailhot 2008-11-22 13:54:34 UTC
Distribution: Fedora Rawhide
Hardware Environment:
GA-EP45-DS5 motherboard, F12 BIOS
http://www.gigabyte.com.tw/Products/Motherboard/Products_Spec.aspx?ClassValue=Motherboard&ProductID=2837

Intel® P45 + ICH10R Chipset + "Gigabyte Sata 2" (JMicron 20360/20363 + Sil5723)
Software Environment: Fedora devel
Problem Description:

I changed my hardware ~ 2 months ago. Since then my Linux boots have been plagued by long sata frobbing. BIOS updates didn't change a thing. Please tell me what's wrong, and if I have to open a Gigabyte ticket, what to tell them
Comment 1 Nicolas Mailhot 2008-11-22 13:55:06 UTC
Created attachment 18972 [details]
Boot logs
Comment 2 Nicolas Mailhot 2008-11-22 13:55:53 UTC
Created attachment 18973 [details]
System lspci
Comment 3 Tejun Heo 2008-11-22 16:33:46 UTC
Hmmm, JMB ahci controller is reporting PHY online but is not responding to init sequence.  Is anything connected to JMB ports?  If not, does connecting a device there make any difference?
Comment 4 Nicolas Mailhot 2008-11-23 00:25:51 UTC
PATA is controlled by the jmicron ship and there is one pata disk in the system. But I don't think the pata bit depends on the same kernel driver (however that does mean I can't disable this ship to workaround the problem)

Gigabyte has done weird stuff with it's sata bios, I wouldn't connect anything I care about there and right now I don't have any spare to test with :( Somehow windows does not complain about it

Please note that while there in nothing on the jmicron-controlled sata ports, they are really Sil5723 ports with the jmicron ship acting as a sort of bridge
Comment 5 Tejun Heo 2008-11-23 01:11:00 UTC
Yeah, those JMB SATA ports are causing trouble.  What did they do to it?  We might need to put the board under blacklist or something.
Comment 6 Tejun Heo 2008-11-23 01:31:18 UTC
Okay, they put two 5723's there.  5723s are really nice when they're in native Port Multiplier mode but it seems they have fixed it to some pseudo device mode.  Can you diddle with the smart backup BIOS options and whether changing it makes the ahci driver act any differently?  If the device is in PMP mode, the driver will be able to discover both downstream ports (ie. four ports in total) connected to the JMB ahci.
Comment 7 Nicolas Mailhot 2008-11-23 02:25:47 UTC
"The ICH10R Southbridge controls six of the SATA ports with a Gigabyte SATA2 controller onboard to support the other four SATA ports. The Gigabyte SATA2 chip controls the IDE connector and has two Sil5723 chips to support the Smart Backup feature of this motherboard. Smart Backup sets up a RAID1 mirror with the primary hard drive partition when another HDD is plugged into one of the four GS ports. Smart Backup works independently of the primary RAID partition."
Comment 8 Nicolas Mailhot 2008-11-23 02:27:41 UTC
"GIGABYTE’s Smart Backup allows users to connect up to 4 Serial ATA devices for effortless RAID data protection. Dual onboard RAID controller chips automatically configure RAID setup without user intervention, making it easier than ever for users to enjoy enhanced data transfer performance, low CPU utilization, real-time backup on-the-fly and protection against HDD failure."
Comment 9 Nicolas Mailhot 2008-11-23 02:28:31 UTC
seems some kind of firmware-controlled mad auto-raid for non-tech people
Comment 10 Nicolas Mailhot 2008-11-23 15:11:11 UTC
(In reply to comment #6)
> Can you diddle with the smart backup BIOS options and whether changing
> it makes the ahci driver act any differently?

There are two smart backup settings in the bios:
1. Smart Backup Function
2. Smart Backup Initial

They were both disabled

The first one is the backup logic, the second one is to force a 5723 mode change when new disks has been plugged in (after which the system reboots and resets the setting to "disabled").

I set Smart Backup Function to "all ports" (you can activate only half the ports if you want) and Smart Backup Initial to "enabled"

Won 10s more of bios init time

Didn't change a thing for Linux
Comment 11 Nicolas Mailhot 2008-11-23 15:13:40 UTC
Created attachment 18992 [details]
Boot logs

Just in case, the boot logs with "Smart Backup Function" set to "All ports" after a "Smart Backup Initial"

Didn't notice any big change
Comment 12 Tejun Heo 2008-11-23 20:50:48 UTC
Aiee... I'll contact SIMG and try to reproduce the problem with the reference 5723 I have around.  Thanks.
Comment 13 Nicolas Mailhot 2008-12-07 03:13:20 UTC
Any news here?
Comment 14 Tejun Heo 2008-12-07 17:27:25 UTC
SIMG hasn't replied yet.  I'll ping them again.
Comment 15 Tejun Heo 2008-12-08 21:32:59 UTC
SIMG responded and I tried to reproduce the problem with my My 5744's (mostly similar but it has USB connection too) but no matter which configuration they are in or whether disks are attached or not, they behave correctly.

Can you please try to connect harddrives to the affected ports and see whether anything changes?
Comment 16 Tejun Heo 2008-12-10 00:22:46 UTC
I've been trying to reproduce the problem without much success yet.  SIMG says it could be dependent on the firmware version.  I'll report when I know more.
Comment 17 Nicolas Mailhot 2008-12-10 01:48:16 UTC
Unfortunately, my hardware is not really adapted to this kind of test.

I have 2 sata disks. There are 4 gigabyte sata ports. Even if I bought new disks the 400W PSU would probably not support 7 disks. And then there is only place for three disks in the enclosure in the first place (the third one is an old PATA windows disk I don't use very often). Plus it's a compact enclosure where you always risk cutting fingers or breaking hardware when trying to change the hardware setup.

If I plug the existing sata disks in the gigabyte sata ports it's likely to activate the stupid auto-backup feature, resulting in data loss.

I'm pretty sure plugging one disk in the gigabyte sata port does not work, I tested it when assembling the case and IIRC there were some boot problems (with hindsight, I was lucky the firmware crap didn't try to change the disk content)

I should have backups. To make them I need to restore the dvd writer to functionality (it does not work with the new board, and I haven't have the time to find out if it's a userspace, kernelspace, or hardware-side failure, and I've exhausted my store of blank disks trying to test it).

So, to make things short, it's not so easy to do what you ask with this hardware. If it really helps I may try to do it sometime next week,
Comment 18 Nicolas Mailhot 2008-12-10 01:49:04 UTC
In the meanwhile it seems Gigabyte is using the same ship in all its current boards.
Comment 19 De Cock Xavier 2009-02-19 03:08:11 UTC
I have the same problem, same hardware, and sent a mail to gigabyte pointing to this kernel bug, they might be able to provide some informations.
Comment 20 Nicolas Mailhot 2009-05-25 21:19:12 UTC
Seems fixed in 2.6.30 rc kernels
Comment 21 Nicolas Mailhot 2009-06-27 08:24:05 UTC
It's back starting with kernel-0:2.6.30-1.fc12.x86_64 at least. So now I will fill it as regression
Comment 22 Tejun Heo 2009-06-29 09:39:37 UTC
Can you please attach the output dmidecode?
Comment 23 Nicolas Mailhot 2009-06-29 17:22:59 UTC
Created attachment 22142 [details]
dmidecode output

as requested
Comment 24 Tejun Heo 2009-07-02 11:35:40 UTC
There's a dup bug and I attached a test patch there.  I'm marking this one as duplicate.  Can you please add yourself to bko#13551 and test the patch attached there?  Thanks.

*** This bug has been marked as a duplicate of bug 13551 ***

Note You need to log in before you can comment on or make changes to this bug.