Bug 120721 - NFS4 compatibility issue with Fanotify file access event
Summary: NFS4 compatibility issue with Fanotify file access event
Status: RESOLVED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Trond Myklebust
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-21 06:53 UTC by sanvi singh
Modified: 2016-06-21 08:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.x
Tree: Mainline
Regression: No


Attachments
FANOTIFY TEST PROGRAM (8.34 KB, application/octet-stream)
2016-06-21 06:53 UTC, sanvi singh
Details

Description sanvi singh 2016-06-21 06:53:41 UTC
Created attachment 220771 [details]
FANOTIFY TEST PROGRAM

Overview:
-------------
If we try to access a file on NFS4 mounted volume.. permission issue occurs

Steps to reproduce:
--------------------
1. Run Fanotify test program ( See Attached fanotify test program -> fanotify_test.c: FAN_ACCESS mode)
2. mount a NFS4 volume
3. read/write a file on NFS4

Actual Results: 
------------------
1. cat operation: permission denied
2. vi operation : 
    - if opening existing file: permission denied
    - if we try creating a new file: it says a swap file already exists

Expected Result:
-------------------
1. reading a file should be allowed
2. writing a new file should be allowed

Platform Information:
------------------------
Reproduced this issue on following platforms:

SLES 11 SP2 64 bit: { kernel-version: 3.0.13-0.27-default }
SLES 11 SP3 64 bit: { kernel-version: 3.0.76-0.11-default }
SLES 11 SP4 64 bit: { kernel-version: 3.0.101-63-default }

Additional Information:
-------------------------
This issue is not present in :
SLES 12 {kernel version: 3.12.36-38-default }
SLES 12 SP1 {kernel version: 3.12.57-60.35-default}
Comment 1 Jan Kara 2016-06-21 08:39:08 UTC
So from what you write, the issue is apparently fixed with more recent kernels. From from upstream POV there's nothing to do. If you want SLES 11 kernels fixed, you need to report this through SUSE bugzilla.

Note You need to log in before you can comment on or make changes to this bug.