Bug 12049 - Oops in acpi_system_wakeup_device_seq_show
Oops in acpi_system_wakeup_device_seq_show
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: acpi_other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-16 08:51 UTC by Rafael J. Wysocki
Modified: 2008-11-16 11:19 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-16 08:51:51 UTC
Subject    : Re: Linux 2.6.28-rc5
Submitter  : Bruno Prémont <bonbons@linux-vserver.org>
Date       : 2008-11-16 13:04
References : http://marc.info/?l=linux-kernel&m=122684070215520&w=4
Notify-Also : Frans Pop <elendil@planet.nl>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-11-16 08:53:18 UTC
Caused by:

commit 0794469da3f7b2093575cbdfc1108308dd3641ce
Author: Kay Sievers <kay.sievers@vrfy.org>
Date:   Thu Oct 30 01:18:59 2008 +0100
    ACPI: struct device - replace bus_id with dev_name(), dev_set_name()

    Acked-by: Greg Kroah-Hartman <gregkh@suse.de>
    Signed-Off-By: Kay Sievers <kay.sievers@vrfy.org>
    Signed-off-by: Len Brown <len.brown@intel.com>

First-Bad-Commit ; 0794469da3f7b2093575cbdfc1108308dd3641ce
Comment 2 Rafael J. Wysocki 2008-11-16 08:53:49 UTC
First-Bad-Commit : 0794469da3f7b2093575cbdfc1108308dd3641ce
Comment 3 Rafael J. Wysocki 2008-11-16 11:19:57 UTC
Fixed by commit 77fb61a04a0483ad274ce5c51b02c46c12db3693.

Note You need to log in before you can comment on or make changes to this bug.