Bug 12040 - iwlagn driver segfault in 2.6.28-rc3
iwlagn driver segfault in 2.6.28-rc3
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: Reinette Chatre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-15 15:27 UTC by Rafael J. Wysocki
Modified: 2008-12-04 16:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: ---


Attachments

Description Rafael J. Wysocki 2008-11-15 15:27:33 UTC
Subject    : iwlagn driver segfault in 2.6.28-rc3
Submitter  : Lukas Hejtmanek <xhejtman@ics.muni.cz>
Date       : 2008-11-11 14:34
References : http://marc.info/?l=linux-kernel&m=122641417331593&w=4
Handled-By : reinette chatre <reinette.chatre@intel.com>
Patch      : http://marc.info/?l=linux-kernel&m=122656004505165&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Reinette Chatre 2008-11-15 21:32:50 UTC
The patch referenced in description is incorrect as we are not dealing with uninitialized memory but corrupted memory. A new patch will be submitted.
Comment 2 Rafael J. Wysocki 2008-11-16 04:21:48 UTC
Ignore-Patch : http://marc.info/?l=linux-kernel&m=122656004505165&w=4
Comment 3 Rafael J. Wysocki 2008-11-16 11:39:02 UTC
On Sunday, 16 of November 2008, Carlos R. Mafra wrote:
> 
> [Off-list]
> 
> On Sun 16.Nov'08 at 17:35:21 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12040
> > Subject		: iwlagn driver segfault in 2.6.28-rc3
> > Submitter	: Lukas Hejtmanek <xhejtman@ics.muni.cz>
> > Date		: 2008-11-11 14:34 (6 days old)
> > References	: http://marc.info/?l=linux-kernel&m=122641417331593&w=4
> > Handled-By	: reinette chatre <reinette.chatre@intel.com>
> 
> According to kerneloops.org
> 
> http://www.kerneloops.org/search.php?search=iwl_eeprom_query16&btnG=Function+Search
> 
> this bug is around since 2.6.25.14 and therefore is not a regression, afaict.

Comment 4 Rafael J. Wysocki 2008-11-16 11:40:21 UTC
Dropping for the list of recent regressions.

Note You need to log in before you can comment on or make changes to this bug.