Bug 12034 - snd-hda-intel on Realtek ALC268 chip shows only Master volume (for playback)
snd-hda-intel on Realtek ALC268 chip shows only Master volume (for playback)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Takashi Iwai
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-15 04:20 UTC by Sergey
Modified: 2008-12-13 10:18 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: Yes


Attachments
kernel log, full (35.75 KB, text/plain)
2008-11-18 10:28 UTC, Sergey
Details
kconfig (233.00 KB, application/octet-stream)
2008-11-18 10:47 UTC, Sergey
Details
kernel config (12.16 KB, application/octet-stream)
2008-11-18 10:48 UTC, Sergey
Details

Description Sergey 2008-11-15 04:20:25 UTC
Latest working kernel version: 2.6.27.4
Earliest failing kernel version:
Distribution: Gentoo
Hardware Environment: acer aspire one 110, ALC268 chip
Software Environment: 
Problem Description:
Many controls disappeared!

Steps to reproduce:
make oldconfig, install kernel and modules, reboot and then alsamixer shows only master control for playback, no Headphone, Front Front mic, Beep, and PCM
Comment 1 Takashi Iwai 2008-11-15 09:19:17 UTC
You likely changed your kernel config, e.g. disabled CONFIG_SND_HDA_CODEC_REALTEK.
Comment 2 Sergey 2008-11-15 22:35:16 UTC
no. I tried to switch off other codecs, but never turned off realtek.
Comment 3 Rafael J. Wysocki 2008-11-16 04:22:55 UTC
Notify-Also : Takashi Iwai <tiwai@suse.de>
Comment 4 Takashi Iwai 2008-11-16 12:19:32 UTC
Attach the whole kconfig, and kernel messages.
Also, run alsa-info.sh script with --no-upload option, and attach the generated file.
Comment 5 Takashi Iwai 2008-11-18 04:27:44 UTC
Also, make sure that you are not using alsa-pulse plugin.
For example, on the recent GNOME or KDE of openSUSE 11.1, the pulseaudio is used as the default backend, and the mixer shows only master and capture volumes.
The raw ALSA device can be accessed via -Dhw option.
Comment 6 Sergey 2008-11-18 08:47:58 UTC
i'm not using any gnome plugins since i tried to boot to console. at boot time after kernel upgrade there was message from alsactl (executed at boot time) that in fail to restore levels. i runed alsamixer and saw that most controls disappeared. Sorry that i didn't respond, just was busy.
So.
what is alsa-info.sh? where can i get this script? i have no such script on my system

I will attach kconfig in a mean time, please wait
Comment 7 Takashi Iwai 2008-11-18 08:51:16 UTC
It still doesn't exclude the possibility of pulse plugin.  It might be set up to use it brutally.  Check aplay -v foo.wav and see the output.

alsa-info.sh is found in
    http://www.alsa-project.org/alsa-info.sh
Comment 8 Sergey 2008-11-18 10:28:04 UTC
Created attachment 18914 [details]
kernel log, full
Comment 9 Sergey 2008-11-18 10:47:11 UTC
Created attachment 18915 [details]
kconfig

dunno is it what u wanted to see :\ if no, just let me know, what i have to do exactly
Comment 10 Sergey 2008-11-18 10:48:12 UTC
Created attachment 18916 [details]
kernel config

directly from /proc/config.gz
Comment 11 Sergey 2008-11-18 10:52:37 UTC
http://www.alsa-project.org/db/?f=454c0cb40a17d95c91dc1b625aa50f7ee82ae086 - alsa-info.sh output

(sorry, i forget to specify --no-upload, i hope it's not a problem to go to link)

X failed to start (that's another problem), so i guarantee u that there's no any programs using alsa in any way

aplay -v /usr/share/sounds/alsa/Noise.wav 
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Plug PCM: Route conversion PCM (sformat=S32_LE)
  Transformation table:
    0 <- 0
    1 <- 0
Its setup is:
  stream       : PLAYBACK
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 1
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 8192
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 1024
  period_event : 0
  start_threshold  : 8192
  stop_threshold   : 8192
  silence_threshold: 0
  silence_size : 0
  boundary     : 1073741824
Slave: Soft volume PCM
Control: PCM Playback Volume
min_dB: -51
max_dB: 0
resolution: 256
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 32
  buffer_size  : 8192
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 1024
  period_event : 0
  start_threshold  : 8192
  stop_threshold   : 8192
  silence_threshold: 0
  silence_size : 0
  boundary     : 1073741824
Slave: Direct Stream Mixing PCM
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 32
  buffer_size  : 8192
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 1024
  period_event : 0
  start_threshold  : 8192
  stop_threshold   : 8192
  silence_threshold: 0
  silence_size : 0
  boundary     : 1073741824
Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
Its setup is:
  stream       : PLAYBACK
  access       : MMAP_INTERLEAVED
  format       : S32_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 32
  buffer_size  : 8192
  period_size  : 1024
  period_time  : 21333
  tstamp_mode  : ENABLE
  period_step  : 1
  avail_min    : 1024
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 1073741824
  silence_threshold: 0
  silence_size : 1073741824
  boundary     : 1073741824

that's all
Comment 12 Takashi Iwai 2008-11-18 22:46:12 UTC
Please upload alsa-info.sh output to here.  The link could be deleted at any time.
Comment 13 Takashi Iwai 2008-11-18 22:51:54 UTC
By any reason, the code in patch_realtek.c isn't used but handled by the generic parser.

I have no idea why this happens, at least, from the driver code.  Don't you set any module option for snd-hda-intel, right?

Anyway, try to build with CONFIG_SND_DEBUG=y and CONFIG_SND_DEBUG_VERBOSE=y.  We might see something else.
Comment 14 Sergey 2008-11-22 14:16:47 UTC
Hm.. i have a new suggestion. There is problem in 2.6.27 kernel, not in 2.6.28. The chip is new, and it correctly supportd only by new alsa drivers (which is included in 2.6.28 kernel). After manual install of the most recent alsa drivers i have found that the only controls available is master and PCM for playback, MicBoost, Capture, Digital and input source switch for capture. Internal or external speaker is controlled by hardware, so there's no need in front and headphones controls.
In any case, fresh alsa drivers solved the problem.
Comment 15 Rafael J. Wysocki 2008-11-30 15:25:45 UTC
Handled-By : Takashi Iwai <tiwai@suse.de>
Comment 16 Takashi Iwai 2008-11-30 22:58:25 UTC
What?  You wrote that the last working version was 2.6.27.4, and now it's not about 2.6.28?  Confusing.

Could you summarize again what is the problem at all?
Comment 17 Sergey 2008-12-03 23:23:16 UTC
From the beginning. There was many different controls with 2.6.27.4 kernel, sound worked ok. With install of 2.6.28 kernel many controls disappeared. Ex. in 27 kernel There were Master, PCM and Front control were affecting sound from built-in speakers and Headphones control was affecting sound level in headphones (when they are connected). But, only Master (and PCM sometimes, i saw both variants, dunno how it can be) control are present with 28 kernel. And I thoght, that it's something wrong with sound card driver. But it's ok, because in fact there's no need in this controls. Ex. When headphones are plugged in, then built-in speakers turns off by hardware. So, there's no need in headphones and front control, because they are all controlled by PCM and master.
I belive, this bug should not be opened anymore. Opening this bug was a kind ofmisunderstanding from my side. Thank you people for attention. 

Note You need to log in before you can comment on or make changes to this bug.