Bug 12032 - thinkpad x200 X.server not work with gm4500 graphics
thinkpad x200 X.server not work with gm4500 graphics
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: arrow zhang
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-14 16:44 UTC by Rafael J. Wysocki
Modified: 2008-11-16 03:56 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-14 16:44:55 UTC
Subject    : thinkpad x200 X.server not work with gm4500 graphics
Submitter  : arrow.ebd@gmail.com
Date       : 2008-11-10 15:25
References : http://marc.info/?l=linux-kernel&m=122633081027413&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Keith Packard 2008-11-14 17:34:56 UTC
There were parallel bugs in the kernel and X server on both G45 and GM45 hardware. You need to update your user space driver to version 2.5.1.

There's no way to make this work without getting both pieces fixed; that it worked for you before was a happy coincidence.
Comment 2 arrow zhang 2008-11-15 20:19:33 UTC
Yeah, have fixed, when I install "xf86-video-intel-git 20081116-1", How to check the version ? Closed

Note You need to log in before you can comment on or make changes to this bug.