Bug 12019 - Major increase in the number of wakeups from C3
Major increase in the number of wakeups from C3
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Processor
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-13 07:02 UTC by Mircea Gherzan
Modified: 2008-11-17 15:39 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: Yes


Attachments
.27 boot (30.63 KB, application/octet-stream)
2008-11-13 07:03 UTC, Mircea Gherzan
Details
.28 boot (30.60 KB, application/octet-stream)
2008-11-13 07:03 UTC, Mircea Gherzan
Details
.28 loaded modules (2.88 KB, application/octet-stream)
2008-11-13 07:04 UTC, Mircea Gherzan
Details
.27 powertop output, 20 seconds (2.96 KB, application/octet-stream)
2008-11-13 07:05 UTC, Mircea Gherzan
Details
.28 powertop output, 20 seconds (3.35 KB, application/octet-stream)
2008-11-13 07:05 UTC, Mircea Gherzan
Details
-rc5 powertop output (3.09 KB, application/octet-stream)
2008-11-17 15:36 UTC, Mircea Gherzan
Details

Description Mircea Gherzan 2008-11-13 07:02:38 UTC
Latest working kernel version: 2.6.27.5
Earliest failing kernel version: 2.6.28-rc3
Distribution: Debian Sid
Hardware Environment: Fujitsu-Siemens Lifebook E8110, Intel T2400, 1.5G RAM, GMA950, iwl3945
Software Environment: Gnome 2.22.3
Problem Description:

The processor is woken up from C3 by "extra timer interrupt" around 100 times per second. In .27, under the same conditions, I am able to achieve approx 10 wakeups per second, therefore better C3 residency times.

The testing was done with the RF kill switch ON.

Steps to reproduce: run powertop, apply all hints.
Comment 1 Mircea Gherzan 2008-11-13 07:03:18 UTC
Created attachment 18845 [details]
.27 boot
Comment 2 Mircea Gherzan 2008-11-13 07:03:35 UTC
Created attachment 18846 [details]
.28 boot
Comment 3 Mircea Gherzan 2008-11-13 07:04:00 UTC
Created attachment 18847 [details]
.28 loaded modules
Comment 4 Mircea Gherzan 2008-11-13 07:05:00 UTC
Created attachment 18848 [details]
.27 powertop output, 20 seconds
Comment 5 Mircea Gherzan 2008-11-13 07:05:23 UTC
Created attachment 18849 [details]
.28 powertop output, 20 seconds
Comment 6 Rafael J. Wysocki 2008-11-16 09:47:23 UTC
Notify-Also : Venkatesh Pallipadi <venkatesh.pallipadi@intel.com>
Comment 7 Rafael J. Wysocki 2008-11-16 09:48:55 UTC
Notify-Also : Thomas Gleixner <tglx@linutronix.de>
Comment 8 ykzhao 2008-11-16 18:03:37 UTC
Hi, Mircea
    From the log in comment #28 it seems that the system is waken up from C3 by "extra timer interrupt" about 117 times. It seems that the above test is done under graphics mode. (In the 2.6.28-rc3 kernel there exists the following info. "hrtimer_wakeup").
    Will you please do the above test under console mode and see whether the problem still exists? When doing test under console mode, please don't load i915 drm driver.
   
   Thanks.
Comment 9 Andreas Mohr 2008-11-17 07:35:24 UTC
Duplicate of #11905 ? If so, then it should work on -rc5.
Comment 10 Mircea Gherzan 2008-11-17 15:36:39 UTC
Created attachment 18899 [details]
-rc5 powertop output
Comment 11 Mircea Gherzan 2008-11-17 15:39:35 UTC
Fixed in -rc5, as seen in the attachment from comment #10.

Note You need to log in before you can comment on or make changes to this bug.