Bug 12015 - Brightness (probably) doesn't supported on FS Amilo Pa 1538
Brightness (probably) doesn't supported on FS Amilo Pa 1538
Status: REJECTED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2008-11-12 04:30 UTC by Przemysław Matekjo
Modified: 2013-04-09 06:23 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: ---


Attachments

Description Przemysław Matekjo 2008-11-12 04:30:00 UTC
Latest working kernel version:none
Earliest failing kernel version:all since 2.6.24 (earlier I doesn't tested)
Distribution:Fedora 10
Hardware Environment:
lspci:
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
05:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)
07:06.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev c0)
lsusb:
Bus 001 Device 002: ID 0bf8:100f Fujitsu Siemens Computers 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Software Environment: Fedora 10 default install
lsmod: video                  28316  0 
output                 11264  1 video
fuse                   60992  2 
cpufreq_ondemand       15504  1 
powernow_k8            24836  1 
freq_table             12928  2 cpufreq_ondemand,powernow_k8
nf_conntrack_netbios_ns    10880  0 
nf_conntrack_ftp       16696  0 
ip6t_REJECT            12160  2 
nf_conntrack_ipv6      22984  11 
ip6table_filter        11136  1 
ip6_tables             26128  1 ip6table_filter
ipv6                  287272  18 ip6t_REJECT,nf_conntrack_ipv6
kqemu                 175128  0 
dm_multipath           23704  0 
snd_hda_intel         476320  3 
nvidia               7797520  28 
snd_seq_dummy          11396  0 
snd_seq_oss            39104  0 
snd_seq_midi_event     14848  1 snd_seq_oss
snd_seq                61968  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            52224  0 
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                85512  2 snd_hda_intel,snd_pcm_oss
snd_timer              30352  2 snd_seq,snd_pcm
snd_page_alloc         16656  2 snd_hda_intel,snd_pcm
snd_hwdep              16392  1 snd_hda_intel
snd                    68984  16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
firewire_ohci          30340  0 
firewire_core          45504  1 firewire_ohci
k8temp                 13056  0 
soundcore              14992  1 snd
forcedeth              61840  0 
hwmon                  11064  1 k8temp
crc_itu_t              10240  1 firewire_core
serio_raw              14084  0 
pcspkr                 11008  0 
i2c_nforce2            15624  0 
i2c_core               29216  2 nvidia,i2c_nforce2
ac                     13320  0 
pata_amd               21252  0 
battery                21000  0 
ata_generic            14084  0 
pata_acpi              13184  0 
sata_nv                32392  2 
sha256_generic         17536  0 
cbc                    12032  1 
aes_x86_64             16384  2 
dm_crypt               21128  1 
ext4                  216120  2 
jbd2                   75464  1 ext4
crc16                  10240  1 ext4

Problem Description: Brightness doesn't work on FS Amilo Pa 1538. After load module "video" /proc/acpi/video is empty. I tested on latest Ubuntu and Gentoo, and it doesn't work too.

Steps to reproduce:
On FS Amilo Pa 1538 insert module video and go to /proc/acpi/video and enter "ls" command
Comment 1 ykzhao 2008-11-13 00:12:35 UTC
Will you  please attach the output of acpidump?
    thanks.
Comment 2 Zhang Rui 2008-11-13 00:35:13 UTC
in order to get the acpidump,
you need to use the latest pmtools at
http://www.lesswatts.org/projects/acpi/utilities.php
Comment 3 Przemysław Matekjo 2008-11-13 05:59:58 UTC
(In reply to comment #2)
> in order to get the acpidump,
> you need to use the latest pmtools at
> http://www.lesswatts.org/projects/acpi/utilities.php
> 
here is the acpidump result:
http://wklej.org/id/17600/
if needed, I can paste it here directly.
Comment 4 ykzhao 2008-11-13 16:54:42 UTC
Thanks for the info. From the acpidump it seems that there exists the following ACPI objects:
   >_DOD, _BCL,_BCM
   But there is no _DOS object, which is required if the system supports display switching or LCD brightness control. 
   At the same time it has the bogus _BCM object, in which nothing can be done. 
   So the problem is related with BIOS. And Linux ACPI can do nothing about it.
   This issue had better be fixed by BIOS upgrading.
   Thanks.
   
Comment 5 Zhang Rui 2008-11-13 17:05:03 UTC
Agree.
the bogus _BCM method suggests that ACPI backlight control is not available on this laptop.
And as it has an external nvidia graphics, I suggest you use some nvidia specific tools to change the backlight. Sorry I don't know what the tool is, but I think you can ask some nvidia experts for help. :)

Re-assign to Video-other category.
please correct me, If I put this bug to the wrong category. :)
Comment 6 Przemysław Matekjo 2008-11-14 05:43:07 UTC
Under Bios I can change the brightness by using Fn+f8 and Fn+f9 - bios remember this settings, separately for battery nad AC. I can also change by nvclock, but the display looks differently than changing in Bios, and each time I invoke nvclock, the zombie-process stay in memory.
Comment 7 Przemysław Matekjo 2008-11-14 08:09:16 UTC
After updating system nvclock doesn't make zombie-process. I made a workaround to change brightness using my own script which uses "/sys/class/power_supply/ACAD/online" state and nvclock. I update Bios to latest version, but unfortunately there are no acpi support for brightness. For me works, but not by using ACPI. 

Note You need to log in before you can comment on or make changes to this bug.