Bug 11992 - [drivers/pcmcia/cistpl.c:357]: Unreachable code
[drivers/pcmcia/cistpl.c:357]: Unreachable code
Status: RESOLVED DUPLICATE of bug 11911
Product: Drivers
Classification: Unclassified
Component: PCMCIA
All Linux
: P1 normal
Assigned To: Dominik Brodowski
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 23:45 UTC by Daniel Marjamäki
Modified: 2008-11-09 12:33 UTC (History)
0 users

See Also:
Kernel Version: latest git tree
Tree: Mainline
Regression: ---


Attachments

Description Daniel Marjamäki 2008-11-08 23:45:45 UTC
The code below the return will never be executed.. it seems to me that brackets are missing.

int verify_cis_cache(struct pcmcia_socket *s)
{
	struct cis_cache_entry *cis;
	char *buf;

	buf = kmalloc(256, GFP_KERNEL);
	if (buf == NULL)
		dev_printk(KERN_WARNING, &s->dev,
			   "no memory for verifying CIS\n");
		return -ENOMEM;
Comment 1 Dominik Brodowski 2008-11-09 12:33:13 UTC
Thanks for spotting this. Patch e689597fe890cf22e23195037aa668c39b25ae4b (already in pcmcia-git) addresses this issue.

*** This bug has been marked as a duplicate of bug 11911 ***

Note You need to log in before you can comment on or make changes to this bug.