Bug 11989 - Suspend failure on NForce4-based boards due to chanes in stop_machine
Suspend failure on NForce4-based boards due to chanes in stop_machine
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: Heiko Carstens
:
Depends on:
Blocks: 7216 11808
  Show dependency treegraph
 
Reported: 2008-11-08 16:20 UTC by Rafael J. Wysocki
Modified: 2008-11-17 11:39 UTC (History)
1 user (show)

See Also:
Kernel Version: commit c9583e55fa2b08a230c549bd1e3c0bde6c50d9cc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-08 16:20:12 UTC
Subject    : Suspend failure on NForce4-based boards due to chanes in stop_machine
Submitter  : "Rafael J. Wysocki" <rjw@sisk.pl>
Date       : 2008-11-03 0:28
References : http://marc.info/?l=linux-kernel&m=122567187604356&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-11-08 16:21:06 UTC
Caused by:

commit c9583e55fa2b08a230c549bd1e3c0bde6c50d9cc
Author: Heiko Carstens <heiko.carstens@de.ibm.com>
Date:   Mon Oct 13 23:50:10 2008 +0200

    stop_machine: use workqueues instead of kernel threads

    Signed-off-by: Heiko Carstens <heiko.carstens@de.ibm.com>
    Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
Comment 2 Rafael J. Wysocki 2008-11-09 11:00:19 UTC
First-Bad-Commit: c9583e55fa2b08a230c549bd1e3c0bde6c50d9cc
Comment 3 Rafael J. Wysocki 2008-11-15 05:34:59 UTC
Handled-By : Rusty Russell <rusty@rustcorp.com.au>
Patch : http://lkml.org/lkml/2008/11/15/69

Note You need to log in before you can comment on or make changes to this bug.