Bug 11983 - iwlagn: wrong command queue 31, command id 0x0
Summary: iwlagn: wrong command queue 31, command id 0x0
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
: 12173 (view as bug list)
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-11-08 15:13 UTC by Rafael J. Wysocki
Modified: 2008-12-11 11:13 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-08 15:13:08 UTC
Subject    : iwlagn: wrong command queue 31, command id 0x0
Submitter  : Matt Mackall <mpm@selenic.com>
Date       : 2008-11-06 4:16
References : http://marc.info/?l=linux-kernel&m=122598672815803&w=4
References : http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1703
Handled-By : reinette chatre <reinette.chatre@intel.com>
Notify-Also : Marcel Holtmann <marcel@holtmann.org>
Notify-Also : "Luis R. Rodriguez" <mcgrof@gmail.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Johannes Berg 2008-11-21 07:54:49 UTC
Some, if not most, instances of this bug are fixed by http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=4018517a1a69a85c3d61b20fa02f187b80773137

apparently some remain, however.
Comment 2 Reinette Chatre 2008-12-03 14:16:01 UTC
Could you please test the firmware available from http://www.intellinuxwireless.org/iwlwifi/downloads/experimental/iwlwifi-4965-ucode-228.57.2.83.tgz 

This is the same firmware provided in comment 52 of http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1703 and reported to solve the issue.

Please post your test results here.
Comment 3 John W. Linville 2008-12-08 11:06:05 UTC
*** Bug 12173 has been marked as a duplicate of this bug. ***
Comment 4 Reinette Chatre 2008-12-11 10:57:44 UTC
Have not received any test results from original submitter. Other users who have encountered this issue (see http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1703 ) reported that the new firmware solved the issue for them.

This new firmware was released today, see http://marc.info/?l=linux-wireless&m=122902161516579&w=2.

This bug can now be closed.
Comment 5 John W. Linville 2008-12-11 11:13:47 UTC
This is a firmware fix, not a patch to the kernel itself.

Note You need to log in before you can comment on or make changes to this bug.