Bug 11982 - Fan level 7 after resume wit 2.6.28-rc3
Fan level 7 after resume wit 2.6.28-rc3
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Henrique de Moraes Holschuh
:
Depends on:
Blocks: 7216 11808
  Show dependency treegraph
 
Reported: 2008-11-08 14:36 UTC by Rafael J. Wysocki
Modified: 2010-10-08 18:20 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: Yes


Attachments
ACPI: thinkpad-acpi: fix fan sleep resume (4.90 KB, patch)
2008-11-09 05:17 UTC, Henrique de Moraes Holschuh
Details | Diff

Description Rafael J. Wysocki 2008-11-08 14:36:25 UTC
Subject    : Fan level 7 after resume wit 2.6.28-rc3
Submitter  : Tino Keitel <tino.keitel@tikei.de>
Date       : 2008-11-05 7:33
References : http://marc.info/?l=linux-kernel&m=122587043409186&w=4
Handled-By : Henrique de Moraes Holschuh <hmh@hmh.eng.br>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Henrique de Moraes Holschuh 2008-11-09 05:17:49 UTC
Created attachment 18744 [details]
ACPI: thinkpad-acpi: fix fan sleep resume

Please test this patch, already sent on the MLs.
Comment 2 Rafael J. Wysocki 2008-11-09 09:22:30 UTC
Patch : http://bugzilla.kernel.org/attachment.cgi?id=18744&action=view
Comment 3 Len Brown 2008-11-11 21:04:10 UTC
patch applied to acpi tree.

categorizing this under "platform drivers", since the feature of restoring
a custom fan setting is specific to thinkpad-acpi.
Comment 4 Rafael J. Wysocki 2008-11-17 13:45:04 UTC
On Monday, 17 of November 2008, Tino Keitel wrote:
> On Sun, Nov 16, 2008 at 17:35:18 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> 
> The fix seems to be still missing from HEAD, but I tested it and it
> fixed the regression that I noticed.

Comment 5 Henrique de Moraes Holschuh 2008-11-27 04:49:55 UTC
Fix on its way to Linus.  Should go into mainline when he is back from his short vacation.

Note You need to log in before you can comment on or make changes to this bug.