Bug 11966 - IRQ smp_affinities not respected
IRQ smp_affinities not respected
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
All Linux
: P1 normal
Assigned To: Jesse Barnes
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-06 16:02 UTC by Rafael J. Wysocki
Modified: 2008-11-10 10:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-06 16:02:40 UTC
Subject    : [BUG] linux-2.6.28-rc3 regression: IRQ smp_affinities not respected
Submitter  : Eric Dumazet <dada1@cosmosbay.com>
Date       : 2008-11-05 6:33
References : http://marc.info/?l=linux-kernel&m=122586683804881&w=4
Handled-By : "Michael Chan" <mchan@broadcom.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-11-06 16:03:54 UTC
Caused by:

Comment 2 Rafael J. Wysocki 2008-11-06 16:05:09 UTC
Caused by:

commit ce6fce4295ba727b36fdc73040e444bd1aae64cd
Author: Matthew Wilcox <matthew@wil.cx>
Date:   Fri Jul 25 15:42:58 2008 -0600

    PCI MSI: Don't disable MSIs if the mask bit isn't supported

    Signed-off-by: Matthew Wilcox <willy@linux.intel.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Comment 4 Michael Chan 2008-11-10 10:41:10 UTC
The fix in comment #3 is for an unrelated issue of reading the VPD past the end tag.  This problem caused the bnx2 driver to fail when trying to open the device.

The problem reported by Eric is SMP affinity no longer working.  This has to do with removing the code to disable MSI (when per-vector masking is not available) before changing the MSI address/data.  As a result, the new MSI address/data will not take effect on some bnx2 chips.

Note You need to log in before you can comment on or make changes to this bug.