Bug 11958 - [2.6.27.x => 2.6.28-rc3] Xorg crash with xf86MapVidMem error
[2.6.27.x => 2.6.28-rc3] Xorg crash with xf86MapVidMem error
Status: CLOSED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-05 05:37 UTC by Tomasz Chmielewski
Modified: 2009-01-06 07:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Tomasz Chmielewski 2008-11-05 05:37:35 UTC
Latest working kernel version: 2.6.27.x
Earliest failing kernel version: 2.6.28-rc?
Distribution: Mandriva Cooker
Hardware Environment: i386
Software Environment: 
Problem Description: X fails to start

Steps to reproduce:

X fails to start for me one one i386 PC with 2.6.28-rc3 kernel and SIS video card. X works fine on the same machine with 2.6.27.x and previous kernels.
I did not try any earlier 2.6.28-rcX kernels (earlier than -rc3).

In Xorg log, with 2.6.28-rc3, it fails after:

(==) SIS(0): Write-combining range (0xf0000000,0x2000000)

Fatal server error:
xf86MapVidMem: Could not mmap framebuffer (0x00000000,0x2000) (Invalid
argument)


2.6.27 shows:

(...)
(==) SIS(0): Write-combining range (0xf0000000,0x2000000)
(II) SIS(0): Setting custom mode 1280x1024 on CRT1
(II) SIS(0): Setting custom mode 1280x1024 on CRT2
(II) SIS(0): RENDER acceleration enabled
(...)

lspci for the video card:

01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760
PCI/AGP or 662/761Gx PCIE VGA Display Adapter (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Siemens Computers Device 1046
        Flags: 66MHz, medium devsel
        BIST result: 00
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at fc100000 (32-bit, non-prefetchable) [size=128K]
        I/O ports at 2000 [size=128]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] AGP version 3.0
        Kernel modules: sisfb



Bug has similar symptoms to http://bugzilla.kernel.org/show_bug.cgi?id=10828
Comment 1 Rafael J. Wysocki 2008-11-16 09:37:11 UTC
Notify-Also : Ingo Molnar <mingo@elte.hu>
Comment 2 Rafael J. Wysocki 2008-11-16 09:38:25 UTC
Tomasz, would it be possible/practical to use bisection identify the commit that caused this to happen?
Comment 3 Rafael J. Wysocki 2008-12-07 13:55:59 UTC
Also, have you tried 2.6.28-rc7 or any newer mainline kernel?
Comment 4 Tomasz Chmielewski 2008-12-15 01:03:03 UTC
I just confirmed that X starts properly on this machine with 2.6.28-rc7 and 2.6.28-rc8.
Comment 5 Thierry Vignaud 2009-01-06 07:04:43 UTC
For me it's the reverse on sis 651.
It worked fine with 2.6.27 but failed with 2.6.28 (I tested rc8, rc9 and final).
See bug #12372
I'm wondering if the fix for a machine hasn't broken another machine.

Note You need to log in before you can comment on or make changes to this bug.