Bug 11937 - ext3 __log_wait_for_space: no transactions
ext3 __log_wait_for_space: no transactions
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: ext3
All Linux
: P1 normal
Assigned To: Theodore Tso
:
: 11935 (view as bug list)
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-11-01 14:56 UTC by Rafael J. Wysocki
Modified: 2008-11-16 09:32 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-11-01 14:56:56 UTC
Subject    : ext3 __log_wait_for_space: no transactions
Submitter  : Meelis Roos <mroos@linux.ee>
Date       : 2008-10-30 9:49
References : http://marc.info/?l=linux-kernel&m=122536026105643&w=4
Handled-By : Theodore Tso <tytso@mit.edu>
Notify-Also : Simon Arlott <simon@fire.lp0.eu>
Notify-Also : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Theodore Tso 2008-11-01 17:53:30 UTC
Rafael, BTW, I had opened Bug 11935 to track this bug.  I guess I'll close 11935 as a dup of your 11937.
Comment 2 Theodore Tso 2008-11-01 17:54:21 UTC
Note: proposed fix at: http://lkml.org/lkml/2008/11/1/61
Comment 3 Theodore Tso 2008-11-01 17:54:36 UTC
*** Bug 11935 has been marked as a duplicate of this bug. ***
Comment 4 Rafael J. Wysocki 2008-11-02 04:07:05 UTC
(In reply to comment #1)
> Rafael, BTW, I had opened Bug 11935 to track this bug.  I guess I'll close
> 11935 as a dup of your 11937.

Yes, thanks.  I missed the creation of bug #11935, sorry.
Comment 5 Luca Tettamanti 2008-11-05 14:23:33 UTC
I also hit this bug, the problem has not reoccurred since I've applied the proposed patch.
Comment 6 Rafael J. Wysocki 2008-11-09 10:45:33 UTC
Patch : http://lkml.org/lkml/2008/11/1/61
Comment 7 Rafael J. Wysocki 2008-11-16 09:32:04 UTC
Fixed by commit e219cca082f52e7dfea41f3be264b7b5eb204227.

Note You need to log in before you can comment on or make changes to this bug.