Bug 11928 - ath5k gets lost with eeepc-laptop removal
ath5k gets lost with eeepc-laptop removal
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: Luis R. Rodriguez
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 14:58 UTC by Rafael J. Wysocki
Modified: 2008-12-01 15:13 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: ---


Attachments

Description Rafael J. Wysocki 2008-10-31 14:58:18 UTC
Subject    : ath5k gets lost with eeepc-laptop removal
Submitter  : "Luiz Fernando N. Capitulino" <lcapitulino@mandriva.com.br>
Date       : 2008-10-31 13:05
References : http://marc.info/?l=linux-kernel&m=122545827204957&w=4
Handled-By : "Nick Kossifidis" <mickflemm@gmail.com>
Notify-Also : Matthew Garrett <mjg59@srcf.ucam.org>
Notify-Also : Alan Jenkins <alan-jenkins@tuffmail.co.uk>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Matthew Garrett 2008-11-02 10:07:35 UTC
This is how the rfkill interface to the hardware behaves. It's not a bug.
Comment 2 Luiz Fernando N. Capitulino 2008-11-04 04:35:04 UTC
Matthew I see your point, but IMHO it doesn't seem acceptable to loose the device when the module is removed.

If it's not a bug we could at least have a workaround for it.
Comment 3 Matthew Garrett 2008-11-04 07:48:38 UTC
The only workaround would be for the rfkill core not to disable the radio on unregistration.
Comment 4 Henrique de Moraes Holschuh 2008-11-04 09:05:25 UTC
No way.  We will remain disabling the radio on unregister.  It is a safety thing.

It can be worked around in eeepc-laptop itself in various ways, although I would recommend against it.

You can have an in-driver flag that you can set before calling the unregister hook, to error out instead of disabling the radio in your toggle_radio() hook,
for example.  Or you could manually re-enable the radio in your driver after
unregistering (which is probably even more annoying than leaving it disabled).

If this was thinkpad-acpi, I would document the platform weirdness, add a DEVELOPER kconfig option to enable the "filter the unregister radio block command" functionality (so as to make it easier on people who need to keep loading/unloading the module) with a suitable printk to know it was enabled when requesting debug logs, and leave it at that.
Comment 5 Rafael J. Wysocki 2008-11-09 10:44:52 UTC
Notify-Also : Luiz Fernando N. Capitulino <lcapitulino@mandriva.com.br>
Comment 6 Rafael J. Wysocki 2008-11-09 12:50:54 UTC
On Sunday, 9 of November 2008, Matthew Garrett wrote:
> It shouldn't be listed as a regression.

Comment 7 Rafael J. Wysocki 2008-11-09 12:51:56 UTC
Dropping from the list of recent regressions.
Comment 8 Luis R. Rodriguez 2008-11-10 11:59:58 UTC
What's the status of this bug report? I fail to see agreement so far. Is it not an issue?
Comment 9 Luis R. Rodriguez 2008-11-14 18:23:00 UTC
Any updates? If not this should be closed....
Comment 10 Luiz Fernando N. Capitulino 2008-11-17 04:38:57 UTC
Well, I think it's up to Matthew to decide.

This doesn't bother me so much any more. If he thinks that this is not an issue this can be closed.
Comment 11 Luis R. Rodriguez 2008-12-01 15:05:43 UTC
Mathew?
Comment 12 Luis R. Rodriguez 2008-12-01 15:13:32 UTC
We've been wanting to help here but no replies yet so will be closing this. Please open the bug up if you decide it is and if so lets get to fixing it.

Note You need to log in before you can comment on or make changes to this bug.