Bug 11925 - cdrom: missing compat ioctls
Summary: cdrom: missing compat ioctls
Status: CLOSED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Block Layer (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: io_other
URL:
Keywords:
Depends on:
Blocks: 11808
  Show dependency tree
 
Reported: 2008-10-31 14:02 UTC by Andreas Schwab
Modified: 2008-12-07 02:18 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Andreas Schwab 2008-10-31 14:02:35 UTC
Latest working kernel version: 2.6.27
Earliest failing kernel version: 2.6.28-rc2
Problem Description:
There is no compat layer for CDROM ioctls.  For whatever reason this worked anyway with <= 2.6.27, at least good enough for hal to correctly handle it (it uses at least CDROM_SET_OPTIONS, CDROM_GET_CAPABILITY and CDROM_DRIVE_STATUS).
Comment 1 Andreas Schwab 2008-10-31 14:13:05 UTC
Looking closer I found 33c2dca4957bd0da3e1af7b96d0758d97e708ef6 (trim file propagation in block/compat_ioctl.c) which removes the compat handling for some of the cdrom ioctls.
Comment 2 Andreas Schwab 2008-10-31 14:45:24 UTC
Patch: http://marc.info/?l=linux-kernel&m=122548923531545&w=2
Comment 3 Rafael J. Wysocki 2008-10-31 15:57:06 UTC
Handled-By : Andreas Schwab <schwab@suse.de>
Comment 4 Rafael J. Wysocki 2008-11-09 10:43:45 UTC
Do I understand correctly that commit 33c2dca4957bd0da3e1af7b96d0758d97e708ef6 caused the problem to happen?
Comment 5 Andreas Schwab 2008-11-09 11:06:02 UTC
Yes.
Comment 6 Rafael J. Wysocki 2008-11-09 11:17:59 UTC
First-Bad-Commit : 33c2dca4957bd0da3e1af7b96d0758d97e708ef6
Comment 7 Rafael J. Wysocki 2008-11-16 09:29:58 UTC
Caused by:

commit 33c2dca4957bd0da3e1af7b96d0758d97e708ef6
Author: Al Viro <viro@zeniv.linux.org.uk>
Date:   Fri Feb 22 22:02:50 2008 -0500

    [PATCH] trim file propagation in block/compat_ioctl.c

    ... and remove the handling of cases when it falls back to native
    without changing arguments.

    Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
Comment 8 Alan 2008-12-04 02:00:28 UTC
Looks good to me

Acked-by: Alan Cox <alan@redhat.com>

Andreas - can you send Linus a copy of that directly ..
Comment 9 Andreas Schwab 2008-12-07 02:18:37 UTC
Merged as 1c925604e1038c7c65b91a92d14dc972b3a70a97.

Note You need to log in before you can comment on or make changes to this bug.