Bug 11911 - new PCMCIA device instance after resume - orinoco can't download firmware
new PCMCIA device instance after resume - orinoco can't download firmware
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCMCIA
All Linux
: P1 normal
Assigned To: Dominik Brodowski
:
: 11992 (view as bug list)
Depends on:
Blocks: 7216 11808
  Show dependency treegraph
 
Reported: 2008-10-30 15:39 UTC by Rafael J. Wysocki
Modified: 2008-11-16 11:22 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-30 15:39:12 UTC
Subject    : [Orinoco-devel] 2.6.28-rc2: new PCMCIA device instance after resume - orinoco can't download firmware
Submitter  : Andrey Borzenkov <arvidjaar@mail.ru>
Date       : 2008-10-28 19:19
References : http://marc.info/?l=linux-wireless&m=122522165719760&w=4
Handled-By : Dave <kilroyd@googlemail.com>
Patch      : http://marc.info/?l=linux-wireless&m=122539058601588&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dominik Brodowski 2008-11-02 04:06:54 UTC
fixed by commit 60df3de8b1f5ce085049e9e3c83d96643c426158 in the pcmcia git tree (pcmcia: fix indentation & braces disagreement - add braces) which will be pushed upstream soon.
Comment 2 kilroyd 2008-11-02 10:25:28 UTC
Commit 60df3de addresses a bug in pcmcia_resource.c::pcmcia_modify_configuration. This bug is concerned with the same issue in cistpl.c::verify_cis_cache.
Comment 3 Dominik Brodowski 2008-11-02 11:00:10 UTC
ah, right -- sorry. Is e689597fe890cf22e23195037aa668c39b25ae4b better?
Comment 4 kilroyd 2008-11-03 13:30:25 UTC
Looks good.
Comment 5 Dominik Brodowski 2008-11-09 12:33:13 UTC
*** Bug 11992 has been marked as a duplicate of this bug. ***
Comment 6 Rafael J. Wysocki 2008-11-10 06:38:32 UTC
On Monday, 10 of November 2008, Andrey Borzenkov wrote:
> On Sunday 09 November 2008, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> 
> Still present in rc4.
> 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=11911
> > Subject		: new PCMCIA device instance after resume - orinoco can't download firmware
> > Submitter	: Andrey Borzenkov <arvidjaar@mail.ru>
> > Date		: 2008-10-28 19:19 (13 days old)
> > References	: http://marc.info/?l=linux-wireless&m=122522165719760&w=4
> > Handled-By	: Dave <kilroyd@googlemail.com>
> > Patch		: http://marc.info/?l=linux-wireless&m=122539058601588&w=4

Comment 7 Rafael J. Wysocki 2008-11-16 11:22:25 UTC
Fixed by commit e689597fe890cf22e23195037aa668c39b25ae4b.

Note You need to log in before you can comment on or make changes to this bug.