Bug 11910 - System doesn't restart
Summary: System doesn't restart
Status: CLOSED DUPLICATE of bug 11942
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
Depends on:
Blocks: 11808
  Show dependency tree
 
Reported: 2008-10-30 15:14 UTC by Rafael J. Wysocki
Modified: 2008-11-09 10:38 UTC (History)
0 users

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-30 15:14:27 UTC
Subject    : 2.6.28-rc2: System doesn't restart
Submitter  : Thomas Meyer <thomas@m3y3r.de>
Date       : 2008-10-30 20:35
References : http://marc.info/?l=linux-kernel&m=122539897518110&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Anonymous Emailer 2008-11-02 14:22:06 UTC
Reply-To: simon@fire.lp0.eu

On 02/11/08 20:30, Michael B. Trausch wrote:
> I started testing 2.6.28 with -rc1 on my system (x86-64, AMD Phenom
> 9500 Quad Core CPU) and found that I was unable to reboot, though I was
> able to with the Ubuntu-provided 2.6.27 kernel.  I have found that a
> commit on 17-Oct-2008 (commit 8fd145917fb62368a9b80db59562c20576238f5a)
> is responsible for this failure to reboot.  Reversing this single change
> on my local kernel (current git tree plus this patch) has enabled me to
> reboot again.
> 
> System board information is attached in the hopes that it will be found
> helpful; if any other information is necessary please let me know.
> 
> The patch that reverts this change is attached, with stat:
> 
>  drivers/acpi/reboot.c |   25 +++----------------------
>  1 files changed, 3 insertions(+), 22 deletions(-)

I'm having the same problem and reverting this commit fixes it too.
Comment 2 Alan Jenkins 2008-11-08 03:46:49 UTC
In that case, this looks like a duplicate of Bug #11942.
Comment 3 Rafael J. Wysocki 2008-11-09 10:38:05 UTC

*** This bug has been marked as a duplicate of bug 11942 ***

Note You need to log in before you can comment on or make changes to this bug.