Bug 11908 - linux-2.6.28-rc2 regression : oprofile doesnt work anymore
linux-2.6.28-rc2 regression : oprofile doesnt work anymore
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-30 15:03 UTC by Rafael J. Wysocki
Modified: 2008-11-10 06:30 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-30 15:03:18 UTC
Subject    : linux-2.6.28-rc2 regression : oprofile doesnt work anymore ?
Submitter  : Eric Dumazet <dada1@cosmosbay.com>
Date       : 2008-10-30 18:01
References : http://marc.info/?l=linux-kernel&m=122539004100532&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-31 15:38:27 UTC
Notify-Also : "Pekka Enberg" <penberg@cs.helsinki.fi>
Notify-Also : Jesper Dangaard Brouer <hawk@comx.dk>
Comment 2 Robert Richter 2008-11-05 07:26:20 UTC
Bug has been introduced with the arch perfmon patcheset. See here:

http://marc.info/?l=linux-kernel&m=122582283607241&w=4
Comment 3 Rafael J. Wysocki 2008-11-09 10:00:27 UTC
Notify-Also : Robert Richter <robert.richter@amd.com>
Comment 4 Rafael J. Wysocki 2008-11-09 10:35:03 UTC
Bisected-To : c493756..5951290
Comment 5 Rafael J. Wysocki 2008-11-09 10:36:43 UTC
First-Bad-Commit : c493756e2a8a78bcaae30668317890dcfe86e7c3
Comment 6 Robert Richter 2008-11-10 02:22:35 UTC
Fixed with:

commit 7c64ade53a6f977d73f16243865c42ceae999aea
Author: Andi Kleen <andi@firstfloor.org>
Date:   Fri Nov 7 14:02:49 2008 +0100

    oprofile: Fix p6 counter overflow check
    
    Fix the counter overflow check for CPUs with counter width > 32
    
    I had a similar change in a different patch that I didn't submit
    and I didn't notice the problem earlier because it was always
    tested together.
    
    Signed-off-by: Andi Kleen <ak@linux.intel.com>
    Signed-off-by: Robert Richter <robert.richter@amd.com>


Upstream in v2.6.28-rc4

Note You need to log in before you can comment on or make changes to this bug.