Bug 11906 - 2.6.28-rc2 seems to fail at powering down the monitor when it should
2.6.28-rc2 seems to fail at powering down the monitor when it should
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-30 14:33 UTC by Rafael J. Wysocki
Modified: 2008-12-12 01:32 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-30 14:33:14 UTC
Subject    : 2.6.28-rc2 seems to fail at powering down the monitor when it should
Submitter  : Gene Heskett <gene.heskett@gmail.com>
Date       : 2008-10-30 6:39
References : http://marc.info/?l=linux-kernel&m=122534879721424&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Gene Heskett 2008-11-09 14:13:00 UTC
AFAICT, its still valid, and FWIW, I built 27.5 this morning and it is not working either.  I am stuck (usually) with a frozen screen blanker clock on a screen that is very much alive.  IIRC, the earlier 27-rc's did work, and I'm slowly working backwards until I find one that does.
Comment 2 Rafael J. Wysocki 2008-11-16 09:25:26 UTC
Can you check if 2.6.27 final works?
Comment 3 Gene Heskett 2008-11-16 09:50:59 UTC
Updated: 2.6.27 final, nor even back to 2.6.26 in small steps, none of them work if I'm using the radeonhd driver from the F8 repo.  With the radeon driver, they all seem to work, but the screen blinking of the radeon driver chases me back to the radeonhd driver in about 10 minutes. 3 seconds off, 10 on, 5 off, 2 on, 3 off, 5 on, 1 off gets a bit like the Easy Rider lsd trip after a while. Very distracting.  :(
Comment 4 Gene Heskett 2008-11-22 15:57:17 UTC
I had a drive failure and have had to re-install, and have not tested the 2.6.28-rc? stuff since.  I was blaming it on the radeonhd driver for a while, but with the stock F8 latest kernel, it (radeonhd) is working.  That's with a 2.6.26-49.fc8 kernel.

It will be several days yet before I get a chance to rejoin the line to bleed over the latest kernel as there are still other issues to resolve with this fresh install.
Comment 5 Rafael J. Wysocki 2008-12-11 11:36:01 UTC
Any chance to check 2.6.28-rc8?

Otherwise I'll have to close this bug due to being stalled.
Comment 6 Gene Heskett 2008-12-11 17:35:33 UTC
Go ahead and close it out as fixed.

I believe it is working for 2.6.28-rc8, there was about a 3 second pause when I came in just now after I moved the mouse, so it must have shut it down,

It has been working correctly since -rc6.  I had forgotten about it, sorry Rafael.

I still don't have this install fully sorted though.  Its being a cast iron bitch.

Gene

Note You need to log in before you can comment on or make changes to this bug.