Bug 11903 - regression: vmalloc easily fail
regression: vmalloc easily fail
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-30 13:44 UTC by Rafael J. Wysocki
Modified: 2008-11-22 13:24 UTC (History)
0 users

See Also:
Kernel Version: commit db64fe02258f1507e13fe5212a989922323685ce
Tree: Mainline
Regression: Yes


Attachments
proposed patch #2 for vmalloc regression (1.25 KB, patch)
2008-11-06 11:03 UTC, Glauber Costa
Details | Diff

Description Rafael J. Wysocki 2008-10-30 13:44:58 UTC
Subject    : [PATCH] regression: vmalloc easily fail.
Submitter  : Glauber Costa <glommer@redhat.com>
Date       : 2008-10-28 20:59
References : http://marc.info/?l=linux-kernel&m=122522755530998&w=4
Handled-By : Glauber Costa <glommer@redhat.com>
Handled-By : Nick Piggin <npiggin@suse.de>
Patch      : http://marc.info/?l=linux-kernel&m=122522755530998&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-30 14:53:26 UTC
Caused by:

commit db64fe02258f1507e13fe5212a989922323685ce
Author: Nick Piggin <npiggin@suse.de>
Date:   Sat Oct 18 20:27:03 2008 -0700

    mm: rewrite vmap layer

    Signed-off-by: Nick Piggin <npiggin@suse.de>
    Cc: Jeremy Fitzhardinge <jeremy@goop.org>
    Cc: Krzysztof Helt <krzysztof.h1@poczta.fm>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 2 Glauber Costa 2008-11-06 11:03:50 UTC
Created attachment 18708 [details]
proposed patch #2 for vmalloc regression 

This is the new proposed patch, I just sent to lkml. Please
let me know if it is better than the previous one.
Comment 3 Rafael J. Wysocki 2008-11-08 15:01:37 UTC
Handled-By : Glauber Costa <glommer@redhat.com>
Patch : http://marc.info/?l=linux-kernel&m=122609055221549&w=4
Comment 4 Rafael J. Wysocki 2008-11-09 09:57:42 UTC
Ignore-Patch : http://marc.info/?l=linux-kernel&m=122522755530998&w=4
Comment 5 Rafael J. Wysocki 2008-11-09 11:16:31 UTC
First-Bad-Commit : db64fe02258f1507e13fe5212a989922323685ce

Note You need to log in before you can comment on or make changes to this bug.