Bug 11894 - 2.6.28-rc2 / hso driver oops
2.6.28-rc2 / hso driver oops
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Serial
All Linux
: P1 normal
Assigned To: Russell King
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-29 16:26 UTC by Rafael J. Wysocki
Modified: 2008-11-09 09:48 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-29 16:26:27 UTC
Subject    : 2.6.28-rc2 / hso driver oops
Submitter  : Jonathan McDowell <noodles@earth.li>
Date       : 2008-10-29 16:40
References : http://marc.info/?l=linux-kernel&m=122529846811013&w=4
Handled-By : Ben Hutchings <bhutchings@solarflare.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 John W. Linville 2008-10-29 16:32:12 UTC
I think this is closer to being a serial driver than anything...
Comment 2 Jonathan McDowell 2008-11-02 10:35:41 UTC
Patch solving this (it's bad rfkill error handling in hso.c) was posted at:

http://lkml.org/lkml/2008/10/30/92

but has had no response.

Patch fixing the HSO error was posted at:

http://lkml.org/lkml/2008/10/30/190

(and has been resent to linux-wireless and acked by Henrique de Moraes Holschuh and Ivo van Doorn)

hso is in drivers/network, but bugzilla doesn't want to let me reassign it there. This isn't a serial issue in any way.
Comment 3 Jonathan McDowell 2008-11-02 10:36:41 UTC
Sorry, that should read that the second patch URL fixes the rfkill error
Comment 4 Rafael J. Wysocki 2008-11-02 10:40:15 UTC
Handled-By : Jonathan McDowell <noodles@earth.li>
Patch : http://lkml.org/lkml/2008/10/30/190
Comment 5 Rafael J. Wysocki 2008-11-03 05:31:33 UTC
Hot-Handled-By : Ben Hutchings <bhutchings@solarflare.com>

Note You need to log in before you can comment on or make changes to this bug.