Bug 118891 - Backport patch from kernel 4.6 that addresses the bogus passive trip point to 0 degrees Celsius
Summary: Backport patch from kernel 4.6 that addresses the bogus passive trip point to...
Status: CLOSED DOCUMENTED
Alias: None
Product: Power Management
Classification: Unclassified
Component: Thermal (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-25 00:40 UTC by Roman Bysh
Modified: 2016-05-26 20:09 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4
Tree: Mainline
Regression: No


Attachments

Description Roman Bysh 2016-05-25 00:40:30 UTC
I'm requesting a backport of commit 81ad4276b505 from kernel 4.6 to kernel 4.4 as it addresses the bogus passive trip point to 0 degrees Celsius.

The patch is essential for Lenovo laptops.

This would be very beneficial for openSUSE 42.2 since "Alpha 1" was recently released for testing. It's kernel will be based on a yearly LTS kernel. 

This year it will be using kernel 4.4.
Comment 1 Zhang Rui 2016-05-25 01:36:37 UTC
commit 81ad4276b505e987dd8ebbdf63605f92cd172b52
Author: Zhang Rui <rui.zhang@intel.com>
Date:   Fri Mar 18 10:03:24 2016 +0800

    Thermal: Ignore invalid trip points
    
    In some cases, platform thermal driver may report invalid trip points,
    thermal core should not take any action for these trip points.
    
    This fixed a regression that bogus trip point starts to screw up thermal
    control on some Lenovo laptops, after
    commit bb431ba26c5cd0a17c941ca6c3a195a3a6d5d461
    Author: Zhang Rui <rui.zhang@intel.com>
    Date:   Fri Oct 30 16:31:47 2015 +0800
    
        Thermal: initialize thermal zone device correctly
    
        After thermal zone device registered, as we have not read any
        temperature before, thus tz->temperature should not be 0,
        which actually means 0C, and thermal trend is not available.
        In this case, we need specially handling for the first
        thermal_zone_device_update().
    
        Both thermal core framework and step_wise governor is
        enhanced to handle this. And since the step_wise governor
        is the only one that uses trends, so it's the only thermal
        governor that needs to be updated.
    
        Tested-by: Manuel Krause <manuelkrause@netscape.net>
        Tested-by: szegad <szegadlo@poczta.onet.pl>
        Tested-by: prash <prash.n.rao@gmail.com>
        Tested-by: amish <ammdispose-arch@yahoo.com>
        Tested-by: Matthias <morpheusxyz123@yahoo.de>
        Reviewed-by: Javi Merino <javi.merino@arm.com>
        Signed-off-by: Zhang Rui <rui.zhang@intel.com>
        Signed-off-by: Chen Yu <yu.c.chen@intel.com>
    
    CC: <stable@vger.kernel.org> #3.18+
    Link: https://bugzilla.redhat.com/show_bug.cgi?id=1317190
    Link: https://bugzilla.kernel.org/show_bug.cgi?id=114551
    Signed-off-by: Zhang Rui <rui.zhang@intel.com>

As you can see, the patch has already been CCed to all stable kernel. I think you should ping stable kernel directly.
Bug report closed as this kernel bugzilla is used to track the problems in the latest upstream kernel.
Comment 2 Zhang Rui 2016-05-25 01:37:55 UTC
or you can reply the patch email directly, and make sure the stable mailing list is CCed. :)
Comment 3 Roman Bysh 2016-05-25 19:19:39 UTC
Understood. Thank you for your time.
Comment 4 Roman Bysh 2016-05-25 19:22:33 UTC
Follow Up

Do you have the list of Lenovo laptops experiencing this problem.
Comment 5 Zhang Rui 2016-05-26 02:04:04 UTC
no, but I think you can dive into the two bug reports referred by the patch and collect those laptop models.
Comment 6 Roman Bysh 2016-05-26 20:09:47 UTC
No problem, I found them.

Note You need to log in before you can comment on or make changes to this bug.