Bug 11882 - dbench 15% regression with 2.6.28-rc1
dbench 15% regression with 2.6.28-rc1
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Peter Zijlstra
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-28 16:19 UTC by Rafael J. Wysocki
Modified: 2008-11-09 09:46 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-28 16:19:33 UTC
Subject    : dbench 15% regression with 2.6.28-rc1
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2008-10-28 8:41
References : http://marc.info/?l=linux-kernel&m=122518333103345&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-31 15:01:45 UTC
Caused by:

commit 695698500912c4479ddf4723e492de3970ff8530
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Tue Sep 23 14:54:23 2008 +0200

    sched: rework wakeup preemption

    Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
Comment 2 Peter Zijlstra 2008-10-31 15:20:15 UTC
On Fri, 2008-10-31 at 15:01 -0700, bugme-daemon@bugzilla.kernel.org
wrote:

> ------- Comment #1 from rjw@sisk.pl  2008-10-31 15:01 -------
> Caused by:
> 
> commit 695698500912c4479ddf4723e492de3970ff8530
> Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
> Date:   Tue Sep 23 14:54:23 2008 +0200
> 
>     sched: rework wakeup preemption
> 
>     Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
>     Signed-off-by: Ingo Molnar <mingo@elte.hu>

Basically reverted by:

commit 464b75273f64be7c81fee975bd6ca9593df3427b
Author: Peter Zijlstra <a.p.zijlstra@chello.nl>
Date:   Fri Oct 24 11:06:15 2008 +0200

    sched: re-instate vruntime based wakeup preemption

    The advantage is that vruntime based wakeup preemption has a better
    conceptual model. Here wakeup_gran = 0 means: preempt when 'fair'.
    Therefore wakeup_gran is the granularity of unfairness we allow in order
    to make progress.

    Signed-off-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
    Acked-by: Mike Galbraith <efault@gmx.de>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

Which is already in -git

Comment 3 Yanmin Zhang 2008-11-03 17:26:26 UTC
I confirm 2.6.28-rc3 fixes it.

Note You need to log in before you can comment on or make changes to this bug.