Bug 11881 - Linux 2.6.28-rc2 i/o error on /dev/ttyUSB0
Linux 2.6.28-rc2 i/o error on /dev/ttyUSB0
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-28 16:17 UTC by Rafael J. Wysocki
Modified: 2008-11-04 09:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-28 16:17:10 UTC
Subject    : Linux 2.6.28-rc2 i/o error on /dev/ttyUSB0
Submitter  : Helge Hafting <helge.hafting@aitel.hist.no>
Date       : 2008-10-28 11:19
References : http://marc.info/?l=linux-kernel&m=122519319922377&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Kalle Valo 2008-10-30 00:40:34 UTC
I experience similar problems with my USB-to-Serial dongle:

tikku:~$ cat /dev/ttyUSB0
cat: /dev/ttyUSB0: Input/output error
tikku:~$ lsmod | grep pl23 
pl2303                 14820  0 
usbserial              27948  2 pl2303
usbcore               124656  9 pl2303,cdc_ether,usbnet,cdc_acm,hci_usb,usbserial,ehci_hcd,uhci_hcd
tikku:~$ 

Using 2.6.28-rc2-wl from wireless-testing tree. I didn't have any problems with 2.6.27-wl.

My dongle:

Bus 001 Device 003: ID 0557:2008 ATEN International Co., Ltd UC-232A Serial Port [pl2303]
Comment 2 Alan 2008-11-04 07:40:29 UTC
Kref fix now in tree

Note You need to log in before you can comment on or make changes to this bug.