Bug 11876 - RCU hang on cpu re-hotplug with 2.6.27rc8
Summary: RCU hang on cpu re-hotplug with 2.6.27rc8
Status: CLOSED CODE_FIX
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-10-28 09:08 UTC by Rafael J. Wysocki
Modified: 2012-12-08 07:27 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-28 09:08:59 UTC
Subject    : RCU hang on cpu re-hotplug with 2.6.27rc8
Submitter  : Andi Kleen <andi@firstfloor.org>
Date       : 2008-10-06 23:28
References : http://marc.info/?l=linux-kernel&m=122333610602399&w=2
Handled-By : "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-12-13 10:46:15 UTC
Andi, does it still happen with the current mainline?
Comment 2 Rafael J. Wysocki 2009-01-11 05:11:36 UTC
This problem appears to have been fixed in current mainline.  Closing.
Comment 3 liaoclarke 2012-12-08 07:27:15 UTC
Rafael, I meet the same problem on 2.6.27-rc7 when testing cpu hotplug on a 4 core SMP machine,
then I go through the history of mainline, find one commit (2133b5d7)which looks like to be related to this bug, but its content is adding a debugging feature on classic RCU, not a bug fix, so do you know in which commit i could find out the solution, thanks.

Note You need to log in before you can comment on or make changes to this bug.