Bug 11875 - radeonfb lockup in .28-rc (bisected)
radeonfb lockup in .28-rc (bisected)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: Benjamin Herrenschmidt
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-28 08:53 UTC by Rafael J. Wysocki
Modified: 2008-12-03 15:28 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-28 08:53:37 UTC
Subject    : radeonfb lockup in .28-rc (bisected)
Submitter  : James Cloos <cloos@jhcloos.com>
Date       : 2008-10-28 0:00
References : http://marc.info/?l=linux-kernel&m=122515210200530&w=4
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-28 08:54:58 UTC
Caused by:

commit b1ee26bab14886350ba12a5c10cbc0696ac679bf
Author: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date:   Wed Oct 15 22:03:46 2008 -0700

    radeonfb: accelerate imageblit and other improvements

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Acked-by: David S. Miller <davem@davemloft.net>
    Cc: Krzysztof Halasa <khc@pm.waw.pl>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 2 Rafael J. Wysocki 2008-11-09 11:12:20 UTC
First-Bad-Commit : b1ee26bab14886350ba12a5c10cbc0696ac679bf
Comment 3 Rafael J. Wysocki 2008-11-11 05:52:20 UTC
References : http://lkml.org/lkml/2008/11/10/12
Comment 4 Alexander Rauth 2008-11-15 02:34:55 UTC
The referenced patched helped here to eliminate the hang on boot ... but there seems to be another problem on shutdown (complete hang). I'll try to evaluate that later on today.
Comment 5 Alexander Rauth 2008-11-15 03:54:54 UTC
Ok, some more information. 
With the patched referenced from Rafael the original described problem vanishes, but terminating X while being on a fb-console will hang the system in the same way. 
Terminating X while the gpu is under X control works fine.

Reverting b1ee26bab14886350ba12a5c10cbc0696ac679bf fixes the problem.

So there seems to be another race .....
Comment 6 Rafael J. Wysocki 2008-11-15 05:21:49 UTC
Patch : http://lkml.org/lkml/2008/11/10/12
Comment 7 Rafael J. Wysocki 2008-11-15 05:22:54 UTC
Alexander, does switching from X to a VT and back causes any problems to happen?
Comment 8 Alexander Rauth 2008-11-15 07:16:57 UTC
Yes switching from X to VT and back works fine.
I've excessive tried VT switching but forget to mention the result ;-)
Comment 9 Alexander Rauth 2008-11-15 07:20:39 UTC
just in case: X driver ist xf86-video-ati-6.9.0
Comment 10 Benjamin Herrenschmidt 2008-11-15 12:59:06 UTC
Rats. Smells like an old X problem that I though fixed. When X is shutdown while not on the front console, it still goes bang the video chip. This is an X bug, I don't see a way to work around it in the kernel other than disabling acceleration completely again :-(

I can try to have a go at fixing X though that won't fix existing distro 

Note You need to log in before you can comment on or make changes to this bug.