Bug 11874 - udev rule for Android USB debugging
udev rule for Android USB debugging
Status: REJECTED INVALID
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 08:50 UTC by Luke Hutchison
Modified: 2008-10-28 11:24 UTC (History)
0 users

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: ---


Attachments

Description Luke Hutchison 2008-10-28 08:50:45 UTC
udev needs the following rule in order to create the correct device node for the Android phone.  It works as a mass storage device without this, but won't work with the debugger, which looks for the right type of entry in /dev/bus/usb in order to detect devices.

SUBSYSTEM=="usb",ATTR{idVendor}=="0bb4",ATTR{idProduct}=="0c02"

Redhat asked that I report this upstream -- I hope this is the right bug tracker for udev.  Ref: https://bugzilla.redhat.com/show_bug.cgi?id=468532
Comment 1 Anonymous Emailer 2008-10-28 10:46:55 UTC
Reply-To: akpm@linux-foundation.org


(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Tue, 28 Oct 2008 08:50:45 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=11874
> 
>            Summary: udev rule for Android USB debugging
>            Product: Other
>            Version: 2.5
>      KernelVersion: 2.6.27
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Other
>         AssignedTo: other_other@kernel-bugs.osdl.org
>         ReportedBy: luke.hutch@gmail.com
> 
> 
> udev needs the following rule in order to create the correct device node for
> the Android phone.  It works as a mass storage device without this, but won't
> work with the debugger, which looks for the right type of entry in /dev/bus/usb
> in order to detect devices.
> 
> SUBSYSTEM=="usb",ATTR{idVendor}=="0bb4",ATTR{idProduct}=="0c02"
> 
> Redhat asked that I report this upstream -- I hope this is the right bug
> tracker for udev.  Ref: https://bugzilla.redhat.com/show_bug.cgi?id=468532

Greg, to whom should Luke send a udev patch?

Thanks.

Comment 2 Greg Kroah-Hartman 2008-10-28 11:21:13 UTC
On Tue, Oct 28, 2008 at 10:46:32AM -0700, Andrew Morton wrote:
> 
> Greg, to whom should Luke send a udev patch?

The udev team, which can be found at linux-hotplug@vger.kernel.org.

kernel.org bugzilla is not for udev, sorry, I'll close this out.

Comment 3 Greg Kroah-Hartman 2008-10-28 11:22:03 UTC
On Tue, Oct 28, 2008 at 10:46:32AM -0700, Andrew Morton wrote:
> > udev needs the following rule in order to create the correct device node for
> > the Android phone.  It works as a mass storage device without this, but won't
> > work with the debugger, which looks for the right type of entry in /dev/bus/usb
> > in order to detect devices.
> > 
> > SUBSYSTEM=="usb",ATTR{idVendor}=="0bb4",ATTR{idProduct}=="0c02"

I really think this is not the correct thing to be doing here, but
please bring it up on the linux-hotplug@vger.kernel.org mailing list,
with full details of why this ruls is necessary (hint, I don't think it
does anything...)

Comment 4 Greg Kroah-Hartman 2008-10-28 11:24:00 UTC
udev bugs are not for kernel.org
Comment 5 Luke Hutchison 2008-10-28 21:09:39 UTC
It doesn't look like the rule does anything, but the /dev/usb/###/### node
is not created without the rule.  Why would that be?  Shouldn't device nodes
always be created when a USB device is plugged in, whether or not the device
is recognized by the system?

I actually already sent an email to the address you specified already, and
it bounced -- I just went back and re-read the bounce message and realized
it was because HTML messages are automatically rejected [ :-) ], I just
assumed the address didn't exist or something...

I will re-send the email now, thanks!

Luke


On Tue, Oct 28, 2008 at 2:18 PM, Greg KH <greg@kroah.com> wrote:

> On Tue, Oct 28, 2008 at 10:46:32AM -0700, Andrew Morton wrote:
> > > udev needs the following rule in order to create the correct device
> node for
> > > the Android phone.  It works as a mass storage device without this, but
> won't
> > > work with the debugger, which looks for the right type of entry in
> /dev/bus/usb
> > > in order to detect devices.
> > >
> > > SUBSYSTEM=="usb",ATTR{idVendor}=="0bb4",ATTR{idProduct}=="0c02"
>
> I really think this is not the correct thing to be doing here, but
> please bring it up on the linux-hotplug@vger.kernel.org mailing list,
> with full details of why this ruls is necessary (hint, I don't think it
> does anything...)
>
It doesn&#39;t look like the rule does anything, but the /dev/usb/###/### node is not created without the rule.&nbsp; Why would that be?&nbsp; Shouldn&#39;t device nodes always be created when a USB device is plugged in, whether or not the device is recognized by the system?<br>
<br>I actually already sent an email to the address you specified already, and it bounced -- I just went back and re-read the bounce message and realized it was because HTML messages are automatically rejected [ :-) ], I just assumed the address didn&#39;t exist or something...<br>
<br>I will re-send the email now, thanks!<br><br>Luke<br><br><br><div class="gmail_quote">On Tue, Oct 28, 2008 at 2:18 PM, Greg KH <span dir="ltr">&lt;<a href="mailto:greg@kroah.com">greg@kroah.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">On Tue, Oct 28, 2008 at 10:46:32AM -0700, Andrew Morton wrote:<br>
</div><div class="Ih2E3d">&gt; &gt; udev needs the following rule in order to create the correct device node for<br>
&gt; &gt; the Android phone. &nbsp;It works as a mass storage device without this, but won&#39;t<br>
&gt; &gt; work with the debugger, which looks for the right type of entry in /dev/bus/usb<br>
&gt; &gt; in order to detect devices.<br>
&gt; &gt;<br>
&gt; &gt; SUBSYSTEM==&quot;usb&quot;,ATTR{idVendor}==&quot;0bb4&quot;,ATTR{idProduct}==&quot;0c02&quot;<br>
<br>
</div>I really think this is not the correct thing to be doing here, but<br>
please bring it up on the <a href="mailto:linux-hotplug@vger.kernel.org">linux-hotplug@vger.kernel.org</a> mailing list,<br>
with full details of why this ruls is necessary (hint, I don&#39;t think it<br>
does anything...)<br>
</blockquote></div><br>

Note You need to log in before you can comment on or make changes to this bug.