Bug 118601 - Table Signature - ACPI Error: [\_SB_.PRAD] Namespace lookup failure, AE_NOT_FOUND
Summary: Table Signature - ACPI Error: [\_SB_.PRAD] Namespace lookup failure, AE_NOT_F...
Status: CLOSED MOVED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-20 09:59 UTC by Olga
Modified: 2017-07-04 01:27 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.x
Tree: Mainline
Regression: No


Attachments
dmesg log (8.81 KB, text/plain)
2016-05-20 09:59 UTC, Olga
Details
acpidump (3.81 MB, application/octet-stream)
2016-05-23 08:30 UTC, Olga
Details

Description Olga 2016-05-20 09:59:19 UTC
Created attachment 216971 [details]
dmesg log

We faced with acpi problem in our Supermicro SYS-5027R-WRF server, motherboard X9SRW-F. We have latest BIOS version 3.2a from Supermicro. We tested Debian 8 and CentOS 7 distros with default kernels. This problem doesn't appear in old 2.6 kernels with CentOS 6 for example. We also tried Debian's 4.x kernel and this problem still exists. Is it critical problem? Or we can just use 3.16 kernels and ignore this messages and disable these events?

Here are these two errors:
[    0.410480] ACPI Error: [\_SB_.PRAD] Namespace lookup failure, AE_NOT_FOUND (20130517/psargs-359)
[    0.410483] ACPI Error: Method parse/execution failed [\_GPE._L24] (Node ffff880853ca18c0), AE_NOT_FOUND (20130517/psparse-536)
[    0.410487] ACPI Exception: AE_NOT_FOUND, while evaluating GPE method [_L24] (20130517/evgpe-579)
Comment 1 Zhang Rui 2016-05-21 02:59:33 UTC
please attach the acpidump output.
Comment 2 Olga 2016-05-23 08:30:29 UTC
Created attachment 217101 [details]
acpidump

Attached acpidump
Comment 3 Zhang Rui 2016-05-31 05:45:27 UTC
These warning messages are not important to me.
The root cause is that, BIOS provides an ACPI table named PRAD, which provides the ACPI processor aggregator device.
But unfortunately, this table can not be recognized properly because the table has an invalid signature, aka, PRAD.
This problem actually exists on all kernel versions, because ACPI never supports a "PRAD" table.
I will close this bug as this is a firmware issue to me, and it's safe for you to use any kernel versions with the error messages. Maybe Lv can explain why these error messages do not exist in earlier kernels.
Comment 4 Olga 2016-05-31 08:20:12 UTC
Thanks for help! 

Last question. Does this [\_GPE._L24] also relate to this problem with PRAD table and we can ignore it?
Comment 5 Zhang Rui 2016-05-31 08:20:59 UTC
yes.
Comment 6 Lv Zheng 2017-05-10 03:21:15 UTC
Hi

I'll re-open this bug.
Looks like a bug in ACPICA.

When AML code specifies a table signature, what's the benefit of AML interpreter to disallow tables named with such signature to be loaded?

And such bugs are not isolated.
We can see several similar issues.

I suppose this issue can be fixed by this pull request:
https://github.com/acpica/acpica/pull/121
And this commit:
Tables: Do not validate signature for dynamic table load …
Comment 7 Zhang Rui 2017-06-16 04:13:51 UTC
lv, if this is an ACPICA bug, please file a ACPICA bug report to track the problem there. thanks!
Comment 8 Lv Zheng 2017-06-26 07:00:01 UTC
OK, linking this bug to this ACPICA bug link:
http://bugs.acpica.org/show_bug.cgi?id=1402

Thanks
Lv
Comment 9 Lv Zheng 2017-07-04 01:27:30 UTC
Patch upstreamed to ACPICA, will appear in Linux upstream soon.
Closing..

Note You need to log in before you can comment on or make changes to this bug.