Bug 11858 - Timeout regression introduced by 242f9dcb8ba6f68fcd217a119a7648a4f69290e9
Timeout regression introduced by 242f9dcb8ba6f68fcd217a119a7648a4f69290e9
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Alan Stern
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-26 04:38 UTC by Rafael J. Wysocki
Modified: 2008-12-07 18:51 UTC (History)
1 user (show)

See Also:
Kernel Version: commit 242f9dcb8ba6f68fcd217a119a7648a4f69290e9
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-26 04:38:01 UTC
Subject    : Timeout regression introduced by 242f9dcb8ba6f68fcd217a119a7648a4f69290e9
Submitter  : Tejun Heo <tj@kernel.org>
Date       : 2008-10-26 9:46
References : http://marc.info/?l=linux-kernel&m=122501447326698&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-26 04:42:06 UTC
This actually is a regression from 2.6.27.
Comment 2 Rafael J. Wysocki 2008-11-09 11:10:52 UTC
First-Bad-Commit : 242f9dcb8ba6f68fcd217a119a7648a4f69290e9
Comment 3 Tejun Heo 2008-12-07 17:14:37 UTC
Rafael, fix for this has already been committed.

f5191ac0987142bda80
Author: Tejun Heo <tj@kernel.org>
Date:   Thu Oct 30 08:32:29 2008 +0100

    block: add timer on blkdev_dequeue_request() not elv_next_request()
    
Comment 4 Alan Stern 2008-12-07 18:51:41 UTC
This bug has been fixed since the beginning of November.  Closing out the report.

Note You need to log in before you can comment on or make changes to this bug.