Bug 11852 - v2.6.28-rc1: Regression in ext3/jbd
v2.6.28-rc1: Regression in ext3/jbd
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: ext3
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-25 13:24 UTC by Rafael J. Wysocki
Modified: 2008-11-02 13:32 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-25 13:24:51 UTC
Subject    : v2.6.28-rc1: Regression in ext3/jbd
Submitter  : "Vegard Nossum" <vegard.nossum@gmail.com>
Date       : 2008-10-25 11:22
References : http://marc.info/?l=linux-kernel&m=122493379905812&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-25 13:31:35 UTC
Caused by:

commit 2d7c820e56ce83b23daee9eb5343730fb309418e
Author: Hidehiro Kawai <hidehiro.kawai.ez@hitachi.com>
Date:   Wed Oct 22 14:15:01 2008 -0700

    ext3: add checks for errors from jbd

    Signed-off-by: Hidehiro Kawai <hidehiro.kawai.ez@hitachi.com>
    Cc: Jan Kara <jack@ucw.cz>
    Cc: Stephen Rothwell <sfr@canb.auug.org.au>
    Cc: Al Viro <viro@zeniv.linux.org.uk>
    Cc: <linux-ext4@vger.kernel.org>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Comment 3 Rafael J. Wysocki 2008-11-02 13:32:16 UTC
Fixed by commit ef2cabf7c6d838eb0ee2b4fb8ef84f7c06ce16d9 .

Note You need to log in before you can comment on or make changes to this bug.