Bug 11848 - 2.6.28-rc1: NCQ devices connected to PMP are still dead
2.6.28-rc1: NCQ devices connected to PMP are still dead
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-25 13:01 UTC by Rafael J. Wysocki
Modified: 2008-10-27 12:55 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc1
Tree: Mainline
Regression: Yes


Attachments
PMP NCQ fix (1.38 KB, patch)
2008-10-27 02:16 UTC, Jens Axboe
Details | Diff

Description Rafael J. Wysocki 2008-10-25 13:01:32 UTC
Subject    : Re: 2.6.27-rc1 (2fca5c): libata: kernel cant boot
Submitter  : Petr Vandrovec <vandrove@vc.cvut.cz>
Date       : 2008-10-25 11:17
References : http://marc.info/?l=linux-kernel&m=122493470907259&w=4
Handled-By : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-25 13:01:58 UTC
Caused by:

commit 2fca5ccf97d2c28bcfce44f5b07d85e74e3cd18e
Author: Jens Axboe <jens.axboe@oracle.com>
Date:   Wed Oct 22 09:34:49 2008 +0200

    libata: switch to using block layer tagging support
Comment 2 Jens Axboe 2008-10-27 02:16:37 UTC
Created attachment 18463 [details]
PMP NCQ fix

Please try this patch.

Note You need to log in before you can comment on or make changes to this bug.