Bug 11845 - Suspend regression on Lenovo x60
Suspend regression on Lenovo x60
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Tomas Winkler
:
Depends on:
Blocks: 7216 11808
  Show dependency treegraph
 
Reported: 2008-10-25 12:42 UTC by Rafael J. Wysocki
Modified: 2008-11-02 15:49 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc1
Tree: Mainline
Regression: Yes


Attachments
syslog from boot to crash after s2ram, with traces at the end (273.55 KB, text/plain)
2008-10-27 13:50 UTC, Carlos R. Mafra
Details

Description Rafael J. Wysocki 2008-10-25 12:42:14 UTC
Subject    : Re: Current suspend issues on Lenovo X200 (w/ Intel graphics)
Submitter  : Jens Axboe <jens.axboe@oracle.com>
Date       : 2008-10-24 18:02
References : http://marc.info/?l=linux-next&m=122487159829507&w=4
Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-27 13:42:19 UTC
References : http://marc.info/?l=linux-kernel&m=122512449714310&w=4

Notify-Also : "Carlos R. Mafra" <crmafra2@gmail.com>

Handled-By : Johannes Berg <johannes@sipsolutions.net>
Patch : http://marc.info/?l=linux-kernel&m=122513311900482&w=4
Comment 2 Carlos R. Mafra 2008-10-27 13:50:05 UTC
Created attachment 18474 [details]
syslog from boot to crash after s2ram, with traces at the end
Comment 3 Johannes Berg 2008-10-28 00:53:02 UTC
Handled-By : Tomas Winkler <tomasw@gmail.com>

I only helped debugging.
Comment 4 Rafael J. Wysocki 2008-10-28 09:03:18 UTC
I know.

Not-Handled-By : Johannes Berg <johannes@sipsolutions.net>
Comment 5 Rafael J. Wysocki 2008-10-28 16:00:10 UTC
Patch : http://marc.info/?l=linux-kernel&m=122514168416505&w=4
Comment 7 Rafael J. Wysocki 2008-11-02 15:46:41 UTC
On Sunday, 2 of November 2008, Carlos R. Mafra wrote:
> On Sun  2.Nov'08 at 17:07:01 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=11845
> > Subject		: Suspend regression on Lenovo x60
> > Submitter	: Jens Axboe <jens.axboe@oracle.com>
> > Date		: 2008-10-24 18:02 (10 days old)
> > References	: http://marc.info/?l=linux-next&m=122487159829507&w=4
> > 		  http://marc.info/?l=linux-kernel&m=122512449714310&w=4
> > Handled-By	: Rafael J. Wysocki <rjw@sisk.pl>
> > 		  Tomas Winkler <tomasw@gmail.com>
> > Patch		: http://marc.info/?l=linux-kernel&m=122513311900482&w=4
> > 		  http://marc.info/?l=linux-wireless&m=122518625308673&w=4
> 
> It is fixed by commit 10d0bd56966571d0324dfd9bbb8aa913a60bef5f which
> is now in Linus' tree.


Note You need to log in before you can comment on or make changes to this bug.