Bug 11838 - general protection fault:  from release_blocks_on_commit
general protection fault:  from release_blocks_on_commit
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: ext4
All Linux
: P1 normal
Assigned To: Theodore Tso
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-25 07:00 UTC by Rafael J. Wysocki
Modified: 2008-11-06 12:45 UTC (History)
2 users (show)

See Also:
Kernel Version: commit 3e624fc72fba09b6f999a9fbb87b64efccd38036
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-25 07:00:15 UTC
Subject    : general protection fault:  from release_blocks_on_commit
Submitter  : Eric Paris <eparis@redhat.com>
Date       : 2008-10-21 14:03
References : http://lkml.org/lkml/2008/10/21/248

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-25 07:00:53 UTC
Reportedly caused by:

commit 3e624fc72fba09b6f999a9fbb87b64efccd38036
Author: Theodore Ts'o <tytso@mit.edu>
Date:   Thu Oct 16 20:00:24 2008 -0400

    ext4: Replace hackish ext4_mb_poll_new_transaction with commit callback
Comment 2 Rafael J. Wysocki 2008-10-27 10:57:40 UTC
On Monday, 27 of October 2008, Eric Paris wrote:
> On Sat, 2008-10-25 at 22:06 +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.27.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=11838
> > Subject		: general protection fault:  from release_blocks_on_commit
> > Submitter	: Eric Paris <eparis@redhat.com>
> > Date		: 2008-10-21 14:03 (5 days old)
> > References	: http://lkml.org/lkml/2008/10/21/248
> 
> Pulled from Linus's git today so it is a 2.6.28-rc2+ kernel and this is
> still a regression I was able to hit.

Comment 3 Rafael J. Wysocki 2008-10-28 16:02:06 UTC
Handled-By : Theodore Tso <tytso@mit.edu>
Patch : http://marc.info/?l=linux-kernel&m=122516096811142&w=4
Comment 4 Theodore Tso 2008-10-28 19:08:43 UTC
I'll be pushing this patch to Linus shortly.
Comment 5 Theodore Tso 2008-11-06 12:45:50 UTC
The patch was pushed to Linus in 2.6.28-rc3, commit ID 6c20ec8503.

Note You need to log in before you can comment on or make changes to this bug.