Bug 118311 - Non-free licensed man pages
Summary: Non-free licensed man pages
Status: RESOLVED CODE_FIX
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-16 21:13 UTC by tcallawa@redhat.com
Modified: 2016-07-12 18:22 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description tcallawa@redhat.com 2016-05-16 21:13:00 UTC
These three files are under licenses which either have restrictions on modification or no permission to modify at all:
"man2/getitimer.2"
"man2/pciconfig_read.2"
"man2/sysinfo.2"

Given the age of these files, it may be difficult to contact the copyright holder to get these files relicensed, but perhaps this is possible.
Comment 1 Michael Kerrisk 2016-07-05 09:17:37 UTC
Tom, what's the problem with man2/sysinfo.2? The page source says that modifications are freely allowed.

Regarding man2/getitimer.2, I've just made some substantial changes to better describe the APIs, and in fact the page has been modified repeatedly over the years, and little of the original text remains. I presume the failure by the original author to grant permission to modify was simply an oversight; certainly, the large number of people who have changed the page have taken that to be the case. In the light of all of these facts (and that I'm the majority author by now), I've changed the license text to note that modifications are freely permitted.

man2/pciconfig_read.2 is a little more tricky. I assume the failure to explicitly mention that modifications are allowed was unintentional. The page has seen modifications over time, but they've all been minor/mechanical. Not sure what to do there. I find no signs of activity on the email address given in the page during the last 10 years, which at the least suggests that email address is no longer active. But, it looks like this is him on LinkedIn:
https://www.linkedin.com/in/niki-rahimi-57766b7. I'll try to contact him.
Comment 2 tcallawa@redhat.com 2016-07-05 17:37:01 UTC
From sysinfo.2

.\" Copyright (C) 1993 by Dan Miner (dminer@nyx.cs.du.edu)
.\"
.\" %%%LICENSE_START(FREELY_REDISTRIBUTABLE)
.\"  Permission is granted to freely distribute or modify this file
.\"  for the purpose of improving Linux or its documentation efforts.
.\"  If you modify this file, please put a date stamp and HOW you
.\"  changed this file.  Thanks.   -DM
.\" %%%LICENSE_END

The "purpose" clause means that any distribution or modification for any other purpose is not permitted.

*****

I concur with you on getitimer.2. I hope you manage to work with the author on pciconfig_read.2 to resolve the issue there. I tried to find a working email address for Dan Miner, but was not successful.
Comment 3 Michael Kerrisk 2016-07-07 06:08:35 UTC
I've had communication with Niki Rahimi, author of pciconfig_read.2, who is fine with changing the license. I've asked Niki to drop a note to the list so that we have an archive of this.
Comment 4 Michael Kerrisk 2016-07-07 07:16:06 UTC
Okay -- I've taken a similar approach to getitimer(2). I have rewritten all except trivial pieces of the sysinfo.2 page, and the structure definitions in any case came from kernel header files. I think this gives me license rights on the page. I've relicensed the page to the "verbatim" license.

When there's a public note from Niki, one of us can close this bug.
Comment 5 Michael Kerrisk 2016-07-07 07:17:01 UTC
Updates pages are now pushed to Git.
Comment 6 Michael Kerrisk 2016-07-12 18:22:48 UTC
Niki has publicly stated that it's okay to change the license. See http://www.spinics.net/lists/linux-man/msg10526.html.

So, all pages are now resolved. Closing.

Note You need to log in before you can comment on or make changes to this bug.