Bug 11830 - disk statistics issue in 2.6.27
Summary: disk statistics issue in 2.6.27
Status: CLOSED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Block Layer (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jens Axboe
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-10-25 06:03 UTC by Rafael J. Wysocki
Modified: 2008-11-16 11:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-25 06:03:36 UTC
Subject    : disk statistics issue in 2.6.27
Submitter  : Miquel van Smoorenburg <mikevs@xs4all.net>
Date       : 2008-10-19 11:31
References : http://marc.info/?l=linux-kernel&m=122441671421326&w=4
Handled-By : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-11-08 16:03:12 UTC
Caused by:

commit 427e59f09fdba387547106de7bab980b7fff77be
Author: James Bottomley <James.Bottomley@HansenPartnership.com>
Date:   Sat Mar 8 18:24:17 2008 -0600

    [SCSI] make use of the residue value

    Cc: Alan Stern <stern@rowland.harvard.edu>
    Signed-off-by: James Bottomley <James.Bottomley@HansenPartnership.com>
Comment 2 Rafael J. Wysocki 2008-11-09 13:07:50 UTC
First-Bad-Commit : 427e59f09fdba387547106de7bab980b7fff77be
Comment 3 Rafael J. Wysocki 2008-11-09 16:00:47 UTC
On Monday, 10 of November 2008, Miquel van Smoorenburg wrote:
> On Sun, 2008-11-09 at 20:43 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.26 and 2.6.27.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.26 and 2.6.27.  Please verify if it still should
> > be listed and let me know (either way).
> 
> The cause has been found - a bug in the dpt_i2o driver that was hidden
> until 2.6.27.
> 
> I've submitted a patch for 2.6.28 which will be included in the next
> -rc, at which point I will submit it for 2.6.27-stable as well.
Comment 4 Miquel van Smoorenburg 2008-11-09 16:17:05 UTC
Report and patch available at:
http://marc.info/?l=linux-scsi&m=122584016807492&w=2
Comment 5 Rafael J. Wysocki 2008-11-09 16:58:32 UTC
Handled-By : Miquel van Smoorenburg <mikevs@xs4all.net>
Patch : http://marc.info/?l=linux-scsi&m=122584016807492&w=2
Comment 6 Rafael J. Wysocki 2008-11-16 11:07:43 UTC
Fixed by commit df81d2371aeca0f7474f197a3090830899016e39.

Note You need to log in before you can comment on or make changes to this bug.