Bug 118291 - Fujitsu Siemens U9210: Adjusting headphone volume does not have an effect
Summary: Fujitsu Siemens U9210: Adjusting headphone volume does not have an effect
Status: RESOLVED DUPLICATE of bug 200107
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-16 13:49 UTC by Joonas Saarinen
Modified: 2018-06-18 20:43 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4.0-22-generic
Tree: Mainline
Regression: No


Attachments

Description Joonas Saarinen 2016-05-16 13:49:11 UTC
Fujitsu Siemens U9210 laptop with Realtek ALC262, Ubuntu 16.04 x86-64

http://www.alsa-project.org/db/?f=0921dd56f8efdb74e605114403f9bc74dd9b4536

Adjusting headphone volume does not have a real effect.

The keyboard volume keys seem to work normally and the volume bar appears on screen. However, the actual volume does not change. It seems to be stuck at about 10% level (rough estimate). Changing volume in Alsamixer has no impact either.

When headphones are plugged in, the audio output is switched to headphones as expected.

Changing internal loudspeaker volume works properly.

I am not sure if this is an ALSA or Pulseaudio bug.
Comment 1 Joonas Saarinen 2016-05-16 14:09:00 UTC
Adjusting the output volume of the docking station headphone output seems to work as well, although this output seems to have a lot of electric noise (I can hear keyboard typing, CPU frequency stepping, etc.).
Comment 2 Raymond 2016-05-16 15:32:54 UTC
which pin complex is HP . dock station output jack >

hdajacksensetest -a


Node 0x15 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Control: name="Line Out Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000003e: IN OUT HP Detect Trigger
  Pin Default 0x02211420: [Jack] HP Out at Ext Front
    Conn = 1/8, Color = Black
    DefAssociation = 0x2, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=02, enabled=1
  Connection: 2
     0x0c* 0x0d

Node 0x1b [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
  Control: name="Headphone Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x80 0x80]
  Pincap 0x0000173e: IN OUT HP Detect Trigger
    Vref caps: HIZ 50 GRD 80
  Pin Default 0x0121141f: [Jack] HP Out at Ext Rear
    Conn = 1/8, Color = Black
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0xc0: OUT HP VREF_HIZ
  Unsolicited: tag=01, enabled=1
  Connection: 2
     0x0c 0x0d*
Comment 3 Joonas Saarinen 2016-05-16 15:59:00 UTC
Okay, I am getting somewhere.

It seems that after plugging in the front headphones, the 'Speaker+LO' mixer setting is automatically set to 0%. It has to be manually set to 100% every time after plugging in front headphones (amixer -c 0 sset 'Speaker+LO' 100%). Then I have a working volume control. What kind of fix is required?

What comes to the dock headphone noise, I tried disabling Loopback Mixing, but it did not help in this case. Maybe the dock is simply electrically badly designed. The sound quality of the front headphone jack is excellent.
Comment 4 Raymond 2016-05-17 01:00:17 UTC
(In reply to Joonas Saarinen from comment #3)
> Okay, I am getting somewhere.
> 
> It seems that after plugging in the front headphones, the 'Speaker+LO' mixer
> setting is automatically set to 0%. It has to be manually set to 100% every
> time after plugging in front headphones (amixer -c 0 sset 'Speaker+LO'
> 100%). Then I have a working volume control. What kind of fix is required?

https://cgit.freedesktop.org/pulseaudio/pulseaudio/commit/src/modules/alsa/mixer/paths/analog-output-lineout.conf?id=9d0a5b5cb7ea3adc1b548a6e1e953ee20835e6b6

you need to vhange pulseaudio conf so that it won't switch off the headphone volume
Comment 5 Joonas Saarinen 2018-06-18 20:43:36 UTC

*** This bug has been marked as a duplicate of bug 200107 ***

Note You need to log in before you can comment on or make changes to this bug.