Bug 11828 - Linux 2.6.27-git3: no SD card reader
Summary: Linux 2.6.27-git3: no SD card reader
Status: CLOSED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: MMC/SD (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_mmc-sd
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-25 05:50 UTC by Rafael J. Wysocki
Modified: 2012-05-22 15:02 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27-git3
Tree: Mainline
Regression: No


Attachments

Description Rafael J. Wysocki 2008-10-25 05:50:26 UTC
Subject    : Linux 2.6.27-git3: no SD card reader
Submitter  : "J.A. Magallón" <jamagallon@ono.com>
Date       : 2008-10-14 0:54
References : http://marc.info/?l=linux-kernel&m=122394573904699&w=4
Handled-By : Pierre Ossman <drzeus-list@drzeus.cx>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alan Jenkins 2008-11-15 08:02:18 UTC
Apparently the SD reader can be detected using the acpiphp driver, using a recent patch

<http://marc.info/?l=linux-kernel&m=122675361011422&w=2>

I assume it's this patch:

<http://marc.info/?l=linux-pci&m=122662042229570&w=2>

(there's a second patch as well, but it's apparently not needed to fix this issue).
Comment 2 Rafael J. Wysocki 2008-11-16 08:59:47 UTC
Patch : http://marc.info/?l=linux-pci&m=122662042229570&w=2
Notify-Also : Matthew Garrett <mjg@redhat.com>
Comment 3 Matthew Garrett 2008-11-16 15:15:08 UTC
I've no comment on whether this is a regression or not, but that patch certainly won't help in this case.
Comment 4 Rafael J. Wysocki 2008-11-16 17:21:31 UTC
Ignore-Patch : http://marc.info/?l=linux-pci&m=122662042229570&w=2
Comment 5 Rafael J. Wysocki 2008-11-22 13:17:54 UTC
Not-Handled-By : Pierre Ossman <drzeus-list@drzeus.cx>
Comment 6 Rafael J. Wysocki 2008-12-07 13:45:45 UTC
According to this message:
http://marc.info/?l=linux-kernel&m=122748305622227&w=4
this is not a regression.  Dropping from the list.

Note You need to log in before you can comment on or make changes to this bug.