Bug 11825 - appletouch broken
appletouch broken
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: Jiri Kosina
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-10-25 03:55 UTC by Johannes Berg
Modified: 2008-10-27 13:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Johannes Berg 2008-10-25 03:55:45 UTC
Latest working kernel version: 2.6.27
Earliest failing kernel version: 2.6.28-rc1, no bisection yet
Distribution: debian/unstable
Hardware Environment: powerbook5,6
Software Environment: ?

Appletouch fails to bind the device, loading it merely yields:

usbcore: registered new interface driver appletouch
Comment 1 Jiri Slaby 2008-10-25 05:43:41 UTC
Should be fixed in hid HEAD, not pulled by Linus so far, so not closing...
Comment 2 Rafael J. Wysocki 2008-10-25 05:45:25 UTC
References : http://marc.info/?l=linux-kernel&m=122433436930451&w=4

Handled-By : Jiri Slaby <jirislaby@gmail.com>
Handled-By : Jiri Kosina <jkosina@suse.cz>

Patch : http://marc.info/?l=linux-kernel&m=122442584100873&w=4
Comment 3 Johannes Berg 2008-10-27 00:54:16 UTC
Kernel with that patch doesn't compile:

drivers/hid/hid-core.c: In function ‘hid_ignore’:
drivers/hid/hid-core.c:1589: error: ‘struct hid_device’ has no member named ‘type’
drivers/hid/hid-core.c:1589: error: ‘HID_TYPE_MOUSE’ undeclared (first use in this function)
drivers/hid/hid-core.c:1589: error: (Each undeclared identifier is reported only once
drivers/hid/hid-core.c:1589: error: for each function it appears in.)
Comment 6 Jiri Slaby 2008-10-27 01:04:09 UTC
References : http://marc.info/?l=linux-kernel&m=122433436930451&w=4

Handled-By : Jiri Slaby <jirislaby@gmail.com>
Handled-By : Jiri Kosina <jkosina@suse.cz>

Patch : http://lkml.org/lkml/2008/10/21/358
Patch : http://lkml.org/lkml/2008/10/21/359

For some reason I can't find it on marc. Also I hope I didn't mess up the format of this message.
Comment 7 Jiri Kosina 2008-10-27 03:11:52 UTC
The fix is now present in Linus tree, commits b4d8e4736c9 and a73a63701.
Comment 8 Rafael J. Wysocki 2008-10-27 04:20:29 UTC
(In reply to comment #6)
> References : http://marc.info/?l=linux-kernel&m=122433436930451&w=4
> 
> Handled-By : Jiri Slaby <jirislaby@gmail.com>
> Handled-By : Jiri Kosina <jkosina@suse.cz>
> 
> Patch : http://lkml.org/lkml/2008/10/21/358
> Patch : http://lkml.org/lkml/2008/10/21/359
> 
> For some reason I can't find it on marc. Also I hope I didn't mess up the
> format of this message.

The format is fine. :-)
Comment 9 Rafael J. Wysocki 2008-10-27 13:14:52 UTC
*** Bug 11869 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.