Bug 118051 - Sound crashes in Dell XPS 13
Summary: Sound crashes in Dell XPS 13
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-11 22:57 UTC by Francisco Cribari
Modified: 2016-07-25 09:19 UTC (History)
6 users (show)

See Also:
Kernel Version: 4.5.3
Tree: Mainline
Regression: No


Attachments
Information on sound (8.70 KB, text/plain)
2016-05-11 22:57 UTC, Francisco Cribari
Details
kernel configuration (192.24 KB, application/octet-stream)
2016-07-22 05:59 UTC, Keqiao, Zhang
Details
asound.state (10.92 KB, application/octet-stream)
2016-07-22 05:59 UTC, Keqiao, Zhang
Details
attachment-28174-0.html (1.98 KB, text/html)
2016-07-22 15:34 UTC, Willy
Details

Description Francisco Cribari 2016-05-11 22:57:24 UTC
Created attachment 215991 [details]
Information on sound

Hardware: 

cribari@darwin4 ~ $ dmesg | grep "XPS 13"
[    0.000000] DMI: Dell Inc. XPS 13 9343/0310JH, BIOS A07 11/11/2015

i.e., 9343 model with Intel i7, touchscreen, 3200 x 1800 screen resolution, Broadcom wireless. 

Kernel 4.5.3 (Arch Linux):

cribari@darwin4 ~ $ uname -a
Linux darwin4 4.5.3-1-ARCH #1 SMP PREEMPT Sat May 7 20:43:57 CEST 2016 x86_64 GNU/Linux

I have sound when I boot the computer, but dmesg informs: 

[    1.453753] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
[    1.453755] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)

alsa-firmware is installed (version 1.0.29-1). 

Sound is gone after a while, usually when I play YouTube videos or streaming radio from 

http://cbn.globoradio.globo.com/

using Google Chrome or another browser (e.g., Vivaldi). (I mostly use Chrome.) Usually, that happens when I stop the video or streaming radio and try to resume it later. 

When sound is gone, dmesg informs: 

[24294.494682] haswell-pcm-audio haswell-pcm-audio: error: audio DSP boot timeout IPCD 0x0 IPCX 0x0
[24294.811357] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx 0x7fff0000
[24294.811360] haswell-pcm-audio haswell-pcm-audio: error: stream commit failed
[24294.811375] haswell-pcm-audio haswell-pcm-audio: ASoC: haswell-pcm-audio hw params failed: -110
[24295.118072] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx 0x7fff0000
[24295.118076] haswell-pcm-audio haswell-pcm-audio: error: stream commit failed
[24295.118082] haswell-pcm-audio haswell-pcm-audio: ASoC: haswell-pcm-audio hw params failed: -110

Also: 

[24304.578677] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx 0x7fff0000
[24304.578693] haswell-pcm-audio haswell-pcm-audio: error: stream commit failed
[24304.578695]  System PCM: error: failed to commit stream -110
[24304.578698] haswell-pcm-audio haswell-pcm-audio: ASoC: haswell-pcm-audio hw params failed: -110
[24304.578700]  System PCM: ASoC: hw_params FE failed -110
[24304.882091] haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx 0x7fff0000
[24304.882102] haswell-pcm-audio haswell-pcm-audio: error: stream commit failed
[24304.882107]  System PCM: error: failed to commit stream -110
[24304.882112] haswell-pcm-audio haswell-pcm-audio: ASoC: haswell-pcm-audio hw params failed: -110
[24304.882117]  System PCM: ASoC: hw_params FE failed -110

In order to have audio, I am having to compile my kernels with 

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y

What I have installed: 

alsa-firmware v. 1.0.29-1
alsa-lib v. 1.1.1-1
alsa-plugins v. 1.1.1-1
alsa-tools v. 1.1.0-2
alsa-utils v. 1.1.1-1
lib32-alsa-lib v. 1.1.1-1
lib32-alsa-plugins v. 1.1.1-1
pulseaudio v. 8.0-3
pulseaudio-alsa v. 2-3
pulseaudio-bluetooth v. 8.0-3
pulseaudio-equalizer v. 8.0-3
pavucontrol v. 3.0-4
lib32-libpulse v. 0.30-6
libcanberra-pulse v. 0.30-6

It may be the case that kernel 4.5.2 (and later) fixed the problem for some 9343 machines (those with Intel i5 processors, maybe) but not for all.
Comment 1 Francisco Cribari 2016-05-12 12:17:58 UTC
Other people are experiencing similar crashes. See, for instance, 

http://forums.fedoraforum.org/showthread.php?p=1761280

See also comment #54 by Sebastian Plamauer at 

https://bugzilla.redhat.com/show_bug.cgi?id=1313434
Comment 2 Willy 2016-05-12 16:53:53 UTC
Hi there! Just wanted to jump in and second Francisco Cribari, we have the same stats (i7 5600u, 3200x1800, touch), even though a different DMI:

DMI: Dell Inc. XPS 13 9343/0F5KF3, BIOS A07 11/11/2015

But like him, I cannot get sound on any kernel (for some time now, including and up to 4.5.3-1, my current kernel), UNLESS (the DMAC_CORE options have no effect) the kernel is recompiled with:

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y

Which, as u all know, causes:

[ 0.000000] ACPI: DMI detected: DELL XPS 13 (2015) (force ACPI _REV to 5)

But which allows me to get sound!!! For a little bit at least. Like Francisco, sound works for a bit (playing thru Audacious, VLC), but around the time I try watching web clips, maybe with pausing or resuming, sound stops working again, with the message, repeatedly:

kernel: haswell-pcm-audio haswell-pcm-audio: ipc: --message timeout-- ipcx 0x83000000 isr 0x00000000 ipcd 0x00000000 imrx 0x7fff0000
kernel: haswell-pcm-audio haswell-pcm-audio: error: stream commit failed
kernel: haswell-pcm-audio haswell-pcm-audio: ASoC: haswell-pcm-audio hw params failed: -110

Relevant arch bugs: https://bugs.archlinux.org/task/47989 
https://bugs.archlinux.org/task/48936

In addition, when the sound stops working, any operation that emits sound or makes a call to pulseaudio will BLOCK, sometimes indefinitely, sometimes for a minute or two. This includes calling alsamixer from the commandline, starting audacious, gnome ui alert sounds, etc.
Comment 3 Francisco Cribari 2016-05-13 19:54:05 UTC
I extracted "IntcPP01.bin" from a copy of a Windows Realtek Audio driver (9343_Audio_Driver_X22K2_WN32_7422.118.0_A01.EXE) and placed it in /usr/lib/firmware/intel/IntcPP01.bin . It did not help. The same crashes took place after that.
Comment 4 Raydonal Ospina 2016-05-20 02:46:51 UTC
Hi, I have a Dell XPS notebook 

[raydonal@buda ~] $ dmesg | grep "XPS 13"
[    0.000000] DMI: Dell Inc. XPS 13 9343/0310JH, BIOS A03 03/25/2015

and this bug also affects me. I have been unable to get sound to work.
Comment 5 Francisco Cribari 2016-05-21 19:53:41 UTC
Today I experienced yet another crash. dmesg dump available at 

http://pastebin.com/HNy18qyZ

Any suggestions?
Comment 6 Nicholas Narsing 2016-05-24 01:03:44 UTC
Maybe this bug should be filed in the category Drivers > Sound(ALSA) instead.
Comment 7 Francisco Cribari 2016-05-24 01:56:34 UTC
@Nicholas Narsing (#6) 

Done: https://bugzilla.kernel.org/show_bug.cgi?id=118781
Comment 8 Francisco Cribari 2016-05-24 12:01:43 UTC
@Nicholas Narsing This may be a kernel bug. This computer has a Realtek ALC3263 chipset, which is "dual-mode", i.e., it supports both the HDA standard and the I2S standard. The embedded controller in the notebook uses the ACPI _REV value provided by the OS you use to determine which mode the sound chipset should be initialized in at boot. Up until kernel 4.3, Fedora and Arch were conservative and selected HDA. Starting with kernel 4.4, they moved to I2S and sound stopped working on all Dell XPS 13 9343 machines. The computer's Arch wiki page

https://wiki.archlinux.org/index.php/Dell_XPS_13_(2015)

claims that kernel 4.5.2 fixed the issue. It seems, however, that it fixed the problem for some 9343 machines but not for others. 

See, for instance, 

https://bugs.archlinux.org/task/47989

The notebook is sold with different configurations. My machine is 

cribari@darwin4 ~ $ dmesg | grep "XPS 13"
[    0.000000] DMI: Dell Inc. XPS 13 9343/0310JH, BIOS A07 11/11/2015

i.e., the 9343 model with Intel i7, touchscreen, 3200 x 1800 screen resolution, Broadcom wireless. 

I started having this problem with kernel 4.4 in Fedora Linux, when sound was changed to I2S. I then filed the following bug report: 

https://bugzilla.redhat.com/show_bug.cgi?id=1313434
Comment 9 Nicholas Narsing 2016-05-24 15:03:34 UTC
@Francisco, I am aware of the problem, I am the person from the Arch bug tracker who suggested that you report the issue here.

In my previous comment, I was simply suggesting that you filed the bug in the wrong category and that may be why no one has responded. Try changing it to Drivers > Sound(ALSA).
Comment 10 Francisco Cribari 2016-05-31 17:07:58 UTC
I believe the crashes are caused by gdm .
Comment 11 Francisco Cribari 2016-06-01 15:56:01 UTC
I believe the crashes that I described above are caused by gdm. They do not happen when LightDM is used. Is there anything that can be done to prevent such crashes short of disabling gdm? gdm starts an instance of pulseaudio. I followed the suggestion here: 

https://wiki.archlinux.org/index.php/Bluetooth_headset#Gnome_with_GDM

That is, created /var/lib/gdm/.config/pulse/client.conf (I did not have this file) with 

autospawn = no
daemon-binary = /bin/true

and 

sudo -ugdm mkdir -p /var/lib/gdm/.config/systemd/user
sudo -ugdm ln -s /dev/null /var/lib/gdm/.config/systemd/user/pulseaudio.socket
[/code]
I rebooted the computer and there was no longer a pulseaudio process for gdm. Nonetheless, the crashes (with I2S sound) persist. 

We should be able to kill pulseaudio and to manually restart it, as described here: 

https://wiki.archlinux.org/index.php/PulseAudio/Examples#Disabling_automatic_spawning_of_PulseAudio_server

However, that does not work for me. After a 

$ pulseaudio --kill

pulseaudio is restarted: 

cribari@darwin4 ~ $ ps aux | grep pulse
cribari  31650  0.0  0.1 497700 11432 ?        S<sl 12:30   0:00 /usr/bin/pulseaudio --daemonize=no
cribari  31869  0.0  0.0  10764  2228 pts/1    S+   12:41   0:00 grep --colour=auto pulse
cribari@darwin4 ~ $ pulseaudio --kill
cribari@darwin4 ~ $ ps aux | grep pulse
cribari  31873  1.6  0.1 498768 11892 ?        S<sl 12:41   0:00 /usr/bin/pulseaudio --daemonize=no
cribari  31880  0.0  0.0  10764  2280 pts/1    S+   12:41   0:00 grep --colour=auto pulse

A discussion about that can be found at 
http://www.dslreports.com/forum/r30355771-Even-if-autospawn-no-PulseAudio-always-starts-gdm

Is there anything else I can try? Thank you.
Comment 12 Keqiao, Zhang 2016-07-22 05:59:12 UTC
Created attachment 224861 [details]
kernel configuration
Comment 13 Keqiao, Zhang 2016-07-22 05:59:39 UTC
Created attachment 224871 [details]
asound.state
Comment 14 Keqiao, Zhang 2016-07-22 06:06:09 UTC
I have retested this issue, but still can not reproduce in our side. 
I used chrome to play some video on web and tried a hundred of times to pause/resume the video randomly, the sound playing normal without any error.

The test ENV are as follows, please refer~
platform: Dell XPS 
BIOS version: A03
CPU: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz

Kernel version: 4.7.0-rc7+
Tree:git: //git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git
Branch: for-next
Commit: 4963cc0bf3a402963884a87e56f7dc73d148c3bd

I also attached the kernel configuration and asound.state, please try it again. Thanks~
Comment 15 Francisco Cribari 2016-07-22 11:37:26 UTC
@Zhang A Fedora developer claimed that I was having a hardware problem. I contacted Dell about that. In my country (Brazil) they do not sell machines with Ubuntu installed and they do not support Linux. After many phone calls back and forth, however, they agreed to change the motherboard of my notebook. (Kudos to Dell!) After that, I have I2S sound and haven't experienced crashes. So, it seems that it was indeed a hardware problem. Several users, however, are still experiencing I2S audio problems in Linux. See, for instance, https://bugzilla.redhat.com/show_bug.cgi?id=1313434 . I am aware of this patch: https://git.kernel.org/cgit/linux/kernel/git/broonie/sound.git/commit/?h=topic/intel&id=a395bdd6b24b692adbce0df6510ec9f2af57573e I hope it will solve some of those problems.
Comment 16 Willy 2016-07-22 15:34:09 UTC
Created attachment 225351 [details]
attachment-28174-0.html

On Jul 22, 2016 07:37, <bugzilla-daemon@bugzilla.kernel.org> wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=118051
>
> --- Comment #15 from Francisco Cribari <cribari@gmail.com> ---
> @Zhang A Fedora developer claimed that I was having a hardware problem. I
> contacted Dell about that. In my country (Brazil) they do not sell machines
> with Ubuntu installed and they do not support Linux. After many phone calls
> back and forth, however, they agreed to change the motherboard of my
> notebook.
> (Kudos to Dell!) After that, I have I2S sound and haven't experienced
> crashes.
> So, it seems that it was indeed a hardware problem. Several users,
> however, are
> still experiencing I2S audio problems in Linux. See, for instance,
> https://bugzilla.redhat.com/show_bug.cgi?id=1313434 . I am aware of this
> patch:
>
>
> https://git.kernel.org/cgit/linux/kernel/git/broonie/sound.git/commit/?h=topic/intel&id=a395bdd6b24b692adbce0df6510ec9f2af57573e
> I hope it will solve some of those problems.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 17 Francisco Cribari 2016-07-22 15:46:11 UTC
@Willy Yes, it was a hardware problem. After Dell replaced the motherboard of my notebook the crashes stopped.
Comment 18 Keqiao, Zhang 2016-07-25 03:18:44 UTC
@Cribari Cool, thanks for your clarification. So please help to close this bug.

Note You need to log in before you can comment on or make changes to this bug.