Bug 11768 - Nokia 6300 storage-mode
Nokia 6300 storage-mode
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 10:42 UTC by Maciej Gierok
Modified: 2009-01-30 12:24 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: ---


Attachments
usbmon (383.16 KB, text/plain)
2008-10-15 14:05 UTC, Maciej Gierok
Details
Nokia 6500 usbmon output (326.72 KB, text/plain)
2008-11-13 18:28 UTC, Francis Russell
Details
usbmon (123.31 KB, application/zip)
2008-12-08 06:05 UTC, Maciej Rutecki
Details
kern.log with usb storage debug (423.93 KB, application/zip)
2008-12-08 06:14 UTC, Maciej Rutecki
Details

Description Maciej Gierok 2008-10-15 10:42:09 UTC
Latest working kernel version: 2.6.26
Earliest failing kernel version: 2.6.27
Distribution: Gentoo
Hardware Environment: USB(ohci,ehci)
Software Environment: gcc-4.3.2, glibc-2.8_p20080602-r0
Problem Description:

When I plug in my Nokia 6300 and chose storage mode nothing happend.
dmesg said:

usb 2-4: configuration #1 chosen from 1 choice 
scsi6 : SCSI emulation for USB Mass Storage devices 
usb-storage: device found at 10 
usb-storage: waiting for device to settle before scanning 
scsi 6:0:0:0: Direct-Access     Nokia    Nokia 6300       0000 PQ: 0 ANSI: 4 
sd 6:0:0:0: [sdc] 248321 512-byte hardware sectors (127 MB) 
sd 6:0:0:0: [sdc] Write Protect is off 
sd 6:0:0:0: [sdc] Mode Sense: 03 00 00 00 
sd 6:0:0:0: [sdc] Assuming drive cache: write through 
sd 6:0:0:0: [sdc] 248321 512-byte hardware sectors (127 MB) 
sd 6:0:0:0: [sdc] Write Protect is off 
sd 6:0:0:0: [sdc] Mode Sense: 03 00 00 00 
sd 6:0:0:0: [sdc] Assuming drive cache: write through 
 sdc: 
sd 6:0:0:0: [sdc] Attached SCSI removable disk 
sd 6:0:0:0: Attached scsi generic sg4 type 0 
usb-storage: device scan complete 
sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0 
sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0 
sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0

and:

sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0

are repeat in never ending loop.

On kernel 2.6.26 it worked OK. I assumed that it may associate whit fix "USB: Fix the Nokia 6300 storage-mode" that I found in kernel 2.6.27-rc8.

Steps to reproduce:
always
Comment 1 Anonymous Emailer 2008-10-15 10:45:08 UTC
Reply-To: akpm@linux-foundation.org


(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Wed, 15 Oct 2008 10:42:10 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=11768
> 
>            Summary: Nokia 6300 storage-mode
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: 2.6.27
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: USB
>         AssignedTo: greg@kroah.com
>         ReportedBy: mgierok@gmail.com
> 
> 
> Latest working kernel version: 2.6.26
> Earliest failing kernel version: 2.6.27

A regression.

> Distribution: Gentoo
> Hardware Environment: USB(ohci,ehci)
> Software Environment: gcc-4.3.2, glibc-2.8_p20080602-r0
> Problem Description:
> 
> When I plug in my Nokia 6300 and chose storage mode nothing happend.
> dmesg said:
> 
> usb 2-4: configuration #1 chosen from 1 choice 
> scsi6 : SCSI emulation for USB Mass Storage devices 
> usb-storage: device found at 10 
> usb-storage: waiting for device to settle before scanning 
> scsi 6:0:0:0: Direct-Access     Nokia    Nokia 6300       0000 PQ: 0 ANSI: 4 
> sd 6:0:0:0: [sdc] 248321 512-byte hardware sectors (127 MB) 
> sd 6:0:0:0: [sdc] Write Protect is off 
> sd 6:0:0:0: [sdc] Mode Sense: 03 00 00 00 
> sd 6:0:0:0: [sdc] Assuming drive cache: write through 
> sd 6:0:0:0: [sdc] 248321 512-byte hardware sectors (127 MB) 
> sd 6:0:0:0: [sdc] Write Protect is off 
> sd 6:0:0:0: [sdc] Mode Sense: 03 00 00 00 
> sd 6:0:0:0: [sdc] Assuming drive cache: write through 
>  sdc: 
> sd 6:0:0:0: [sdc] Attached SCSI removable disk 
> sd 6:0:0:0: Attached scsi generic sg4 type 0 
> usb-storage: device scan complete 
> sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
> sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0 
> sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
> sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0 
> sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
> sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0
> 
> and:
> 
> sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
> sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0
> 
> are repeat in never ending loop.
> 
> On kernel 2.6.26 it worked OK. I assumed that it may associate whit fix "USB:
> Fix the Nokia 6300 storage-mode" that I found in kernel 2.6.27-rc8.
> 
> Steps to reproduce:
> always
> 

Comment 2 Maciej Gierok 2008-10-15 12:18:06 UTC
kernel 2.6.26.6 work OK
kernel 2.6.27-rc1 don't work
kernel 2.6.27-rc7 don't work
kernel 2.6.27-rc8 still don't work
kernel 2.6.27 don't work


Comment 3 Alan Stern 2008-10-15 12:53:24 UTC
> > http://bugzilla.kernel.org/show_bug.cgi?id=11768
> > 
> >            Summary: Nokia 6300 storage-mode

> > When I plug in my Nokia 6300 and chose storage mode nothing happend.

> > sd 6:0:0:0: [sdc] Sense Key : 0x0 [current] 
> > sd 6:0:0:0: [sdc] ASC=0x0 ASCQ=0x0
> > 
> > are repeat in never ending loop.
> > 
> > On kernel 2.6.26 it worked OK. I assumed that it may associate whit fix "USB:
> > Fix the Nokia 6300 storage-mode" that I found in kernel 2.6.27-rc8.

I don't think that patch would have caused the problem.  But we need 
more information to find out what's wrong.

Can you use usbmon to record what happens when you plug in the 6300?  
Instructions are in the kernel source file 
Documentation/usb/usbmon.txt.

Alan Stern

Comment 4 Maciej Gierok 2008-10-15 14:03:53 UTC
Dnia 15-10-2008 o 21:52:51 Alan Stern <stern@rowland.harvard.edu>  
napisał(a):

> Can you use usbmon to record what happens when you plug in the 6300?
> Instructions are in the kernel source file
> Documentation/usb/usbmon.txt.

Is that what you need?


Comment 5 Maciej Gierok 2008-10-15 14:05:43 UTC
Created attachment 18329 [details]
usbmon
Comment 6 Alan Stern 2008-10-15 14:29:55 UTC
On Wed, 15 Oct 2008, Maciej Gierok wrote:

> Dnia 15-10-2008 o 21:52:51 Alan Stern <stern@rowland.harvard.edu>  
> napisał(a):
> 
> > Can you use usbmon to record what happens when you plug in the 6300?
> > Instructions are in the kernel source file
> > Documentation/usb/usbmon.txt.
> 
> Is that what you need?

That's it exactly.  The problem is simple: Your 6300 has newer firmware
than the kernel knows about.  The patch below should fix the problem.

Alan Stern

P.S.: Contrary to what Andrew Morton said, this does not appear to be a 
regression.



Index: usb-2.6/drivers/usb/storage/unusual_devs.h
===================================================================
--- usb-2.6.orig/drivers/usb/storage/unusual_devs.h
+++ usb-2.6/drivers/usb/storage/unusual_devs.h
@@ -240,7 +240,7 @@ UNUSUAL_DEV(  0x0421, 0x04b9, 0x0551, 0x
 		US_FL_FIX_CAPACITY ),
 
 /* Reported by Richard Nauber <RichardNauber@web.de> */
-UNUSUAL_DEV(  0x0421, 0x04fa, 0x0601, 0x0601,
+UNUSUAL_DEV(  0x0421, 0x04fa, 0x0601, 0x0660,
 		"Nokia",
 		"6300",
 		US_SC_DEVICE, US_PR_DEVICE, NULL,

Comment 7 Maciej Gierok 2008-10-15 14:56:50 UTC
Dnia 15-10-2008 o 23:29:51 Alan Stern <stern@rowland.harvard.edu>  
napisał(a):

> That's it exactly.  The problem is simple: Your 6300 has newer firmware
> than the kernel knows about.  The patch below should fix the problem.

Now it works. Thanks for quick help.


Comment 8 Stephane Travostino 2008-10-23 08:25:21 UTC
Same issue with Nokia 5610 XpressMusic, and other models, please see my thread on Archlinux forum: http://bbs.archlinux.org/viewtopic.php?pid=437692

Do I need to open a new bug report for each model or can I post here the debug info?
Comment 9 Fábio Barbosa 2008-10-31 12:24:22 UTC
I want to confirm this bug still appears on 2.6.27-7. I'm a Ubuntu Intrepid user, and back on 2.6.24-16 and 2.6.26-21 I could still connect to my Nokia 6300 through a USB cable, on storage mode. Is there anything I can do to help solve the problem (any report, terminal data, etc.)? Will it be a permanent feature in the kernel, or can we expect a return to the old, successful behavior, in future releases? 
Comment 10 Rene Vielma M 2008-11-10 04:48:09 UTC
(In reply to comment #8)

> Do I need to open a new bug report for each model or can I post here the debug
> info?
> 

+1
I've a Nokia 5200
Comment 11 David McBride 2008-11-11 13:56:58 UTC
Hi,

Earlier versions of the Nokia 6300 firmware -- such as the 5.50, as is currently installed on my phone, also exhibit this problem; I would suggest that the 6300 UNUSUAL_DEV line should have a firmware version lower bound of at least 0x0550.  (This at least fixes this problem for me.)

Indeed, it may be reasonable to assume that all versions of the Nokia 6300 firmware -- the latest version of which is currently 7.00 -- handle USB storage operations incorrectly.

Cheers,
David
Comment 12 Francis Russell 2008-11-13 18:26:09 UTC
I seem to be experiencing a near identical issue, except with a Nokia 6500 with firmware version 3.21. Output from syslog follows. I am also attaching a usbmon output dump collected on kernel 2.6.27.6 to help confirm.

Nov 14 02:06:37 aegir kernel: usb 1-1.1: new full speed USB device using ehci_hcd and address 4
Nov 14 02:06:37 aegir kernel: usb 1-1.1: configuration #1 chosen from 2 choices
Nov 14 02:06:37 aegir kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Nov 14 02:06:37 aegir kernel: usb 1-1.1: New USB device found, idVendor=0421, idProduct=003b
Nov 14 02:06:37 aegir kernel: usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 14 02:06:37 aegir kernel: usb 1-1.1: Product: Nokia 6500c
Nov 14 02:06:37 aegir kernel: usb 1-1.1: Manufacturer: Nokia
Nov 14 02:06:37 aegir kernel: usb 1-1.1: SerialNumber: 358666013388778
Nov 14 02:06:37 aegir kernel: usb-storage: device found at 4
Nov 14 02:06:37 aegir kernel: usb-storage: waiting for device to settle before scanning
Nov 14 02:06:42 aegir kernel: usb-storage: device scan complete
Nov 14 02:06:42 aegir kernel: scsi 3:0:0:0: Direct-Access     Nokia    Nokia 6500c      0000 PQ: 0 ANSI: 4
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] 2007041 512-byte hardware sectors (1028 MB)
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Write Protect is off
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Mode Sense: 04 00 00 00
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Assuming drive cache: write through
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] 2007041 512-byte hardware sectors (1028 MB)
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Write Protect is off
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Mode Sense: 04 00 00 00
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Assuming drive cache: write through
Nov 14 02:06:42 aegir kernel:  sdc:
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: [sdc] Attached SCSI removable disk
Nov 14 02:06:42 aegir kernel: sd 3:0:0:0: Attached scsi generic sg3 type 0
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Sense Key : No Sense [current] 
Nov 14 02:06:43 aegir kernel: sd 3:0:0:0: [sdc] Add. Sense: No additional sense information

repeats...
Comment 13 Francis Russell 2008-11-13 18:28:06 UTC
Created attachment 18857 [details]
Nokia 6500 usbmon output
Comment 14 Radek Dvořák 2008-12-02 14:58:47 UTC
I googled this bug because my Nokia 6300 exhibits exactly the same sympthoms. My phone sw version is 5.00 therefore lower bound version suggested in reply #11 should be lowered accordingly.
Comment 15 Maciej Rutecki 2008-12-08 06:04:24 UTC
I have similar problem like in #12. I use nokia 3110.

T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  4 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0421 ProdID=005e Rev= 6.60
S:  Manufacturer=Nokia
S:  Product=Nokia 3110c
C:* #Ifs=15 Cfg#= 1 Atr=e0 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=08 Prot=01 Driver=(none)
I:* If#= 1 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=cdc_acm
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=0b Prot=00 Driver=(none)
I:* If#= 4 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#= 4 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#= 5 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=0b Prot=00 Driver=(none)
I:* If#= 6 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#= 6 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=84(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#= 7 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=0b Prot=00 Driver=(none)
I:* If#= 8 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#= 8 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=85(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#= 9 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=ff Driver=(none)
E:  Ad=86(I) Atr=03(Int.) MxPS=  64 Ivl=1ms
I:* If#=10 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=87(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=07(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#=11 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=fe Prot=00 Driver=(none)
I:* If#=12 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#=12 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=88(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=08(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:* If#=13 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=fd Prot=00 Driver=(none)
I:* If#=14 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#=14 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=89(I) Atr=03(Int.) MxPS=  64 Ivl=32ms
E:  Ad=09(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms

Kernel 2.6.28-rc7
Comment 16 Maciej Rutecki 2008-12-08 06:05:48 UTC
Created attachment 19208 [details]
usbmon

usbmon from 2.6.28-rc7
Comment 17 Maciej Rutecki 2008-12-08 06:14:18 UTC
Created attachment 19209 [details]
kern.log with usb storage debug
Comment 18 Andrey Karlov 2008-12-15 04:34:48 UTC
> +UNUSUAL_DEV(  0x0421, 0x04fa, 0x0601, 0x0660,
                "Nokia",
                "6300",
                US_SC_DEVICE, US_PR_DEVICE, NULL,

what means 0x0601 and 0x0660? I have some problems with my Nokia 7500 Prism and want to add it into unusual_devs.h . But I don't know 3d and 4th parameters.

UNUSUAL_DEV( 0x0421, 0x0067, ???, ???,
	"Nokia",
	"Nokia 7500",
	US_SC_DEVICE, US_PR_DEVICE, NULL,
	US_FL_FIX_CAPACITY ),
Comment 19 Alan Stern 2008-12-15 07:54:06 UTC
Instead of adding a new entry to unusual_devs.h, try using this patch:

   http://marc.info/?l=linux-usb&m=122927521410276&w=2
Comment 20 Felipe Barriga Richards 2009-01-18 17:30:14 UTC
I'm having the same problem.
If you are going to continue add entries in unusual_devs.h, add this one please:


funstation:~#  lsusb -v -d 152d:2338
>
> Bus 005 Device 003: ID 152d:2338 JMicron Technology Corp. / JMicron USA
> Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
> Device Descriptor:
>  bLength                18
>  bDescriptorType         1
>  bcdUSB               2.00
>  bDeviceClass            0 (Defined at Interface level)
>  bDeviceSubClass         0
>  bDeviceProtocol         0
>  bMaxPacketSize0        64
>  idVendor           0x152d JMicron Technology Corp. / JMicron USA Technology
> Corp.
>  idProduct          0x2338 JM20337 Hi-Speed USB to SATA & PATA Combo Bridge
>  bcdDevice            1.00
>  iManufacturer           1 JMicron
>  iProduct                2 USB to ATA/ATAPI Bridge
>  iSerial                 5 65962AC12222
>  bNumConfigurations      1
>  Configuration Descriptor:
>   bLength                 9
>   bDescriptorType         2
>   wTotalLength           32
>   bNumInterfaces          1
>   bConfigurationValue     1
>   iConfiguration          4 USB Mass Storage
>   bmAttributes         0xc0
>     Self Powered
>   MaxPower                2mA
>   Interface Descriptor:
>     bLength                 9
>     bDescriptorType         4
>     bInterfaceNumber        0
>     bAlternateSetting       0
>     bNumEndpoints           2
>     bInterfaceClass         8 Mass Storage
>     bInterfaceSubClass      6 SCSI
>     bInterfaceProtocol     80 Bulk (Zip)
>     iInterface              6 MSC Bulk-Only Transfer
>     Endpoint Descriptor:
>       bLength                 7
>       bDescriptorType         5
>       bEndpointAddress     0x81  EP 1 IN
>       bmAttributes            2
>         Transfer Type            Bulk
>         Synch Type               None
>         Usage Type               Data
>       wMaxPacketSize     0x0200  1x 512 bytes
>       bInterval               0
>     Endpoint Descriptor:
>       bLength                 7
>       bDescriptorType         5
>       bEndpointAddress     0x02  EP 2 OUT
>       bmAttributes            2
>         Transfer Type            Bulk
>         Synch Type               None
>         Usage Type               Data
>       wMaxPacketSize     0x0200  1x 512 bytes
>       bInterval               0
> Device Qualifier (for other device speed):
>  bLength                10
>  bDescriptorType         6
>  bcdUSB               2.00
>  bDeviceClass            0 (Defined at Interface level)
>  bDeviceSubClass         0
>  bDeviceProtocol         0
>  bMaxPacketSize0        64
>  bNumConfigurations      1
> can't get debug descriptor: Connection timed out
> Device Status:     0x6101
>  Self Powered
> funstation:~#

PS: I'm using it with a s-ata drive.

Thanks
Comment 21 Alan Stern 2009-01-19 08:09:36 UTC
Please don't try to hijack someone else's bug report.  How do you know that your device has the same problem as the Nokia?  Most likely it has a different problem.
Comment 22 János Illés 2009-01-30 10:01:06 UTC
This bug can be closed, 2.6.28.2 has a patch fixing issues with mobile phones. New kerne works fine with my nokia 6300
Comment 23 Greg Kroah-Hartman 2009-01-30 12:24:41 UTC
Thanks for testing, closing out.

Note You need to log in before you can comment on or make changes to this bug.